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Introduction 

Microsoft Visio is flowcharting software that can be used to represent processes, workflows, networks, office 

organizations, data flows, cause and effect diagrams, timelines, floor plans, electrical circuits, charts, and 

more.  This booklet covers the creation of a flowchart, an organizational chart, and a timeline. 

The Microsoft Office 2010 Interface 

The Ribbon 

Figure 1 - The Ribbon 

The ribbon is a panel that contains functional groupings of buttons and drop-down lists organized by tabs. The 

ribbon is designed to help you quickly find the commands that you need to complete a task.   

The ribbon is made up of a set of tabs that pertain to the different functionalities of Visio, such as designing 

pages, inserting objects onto pages, or linking data to shapes. Each tab is further divided into logical groups (of 

buttons), such as the Font group shoǁn aďoǀe. There are also ͞Đontextual taďs͟ that appear, depending on 
what you are working on at that time. For example, if you insert pictures, the Picture Tools tab appears 

whenever a picture is selected (see Figure 2). 

Figure 2 - Contextual Tab 
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The File tab 

  Figure 3 - File Tab 

The File tab provides a centralized location called the Microsoft Office Backstage View, for all tasks related to 

Visio file management, which includes opening, creating, closing, sharing, saving, printing, converting to PDF, 

and emailing. The Backstage View also allows for viewing document properties, removing personal 

information, and reducing the file size by removing unused items. 

Figure 4 – File Tab 
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Flowcharts 

Creating a New Flowchart 

1. Click on the File tab.

2. Choose New.

3. Select the Flowchart template category.

Figure 5 - Flowchart Template Category 

4. Select the flowchart of your choice.

Figure 6 - Flowchart Templates 

5. Select Metric or US Units.

6. Click on the Create button.
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Building the Flowchart 

1. Click and drag a shape from the Shapes window onto the drawing page.

Figure 7 - Inserting Shapes 

2. Repeat the process until all the shapes for the flowchart have been placed.

3. Click the Connector Tool on the ribbon.

4. Click to select a shape on the drawing page.  Connecting arrows appear around the shape.

Figure 8 - Connecting Arrows 

5. Place the mouse cursor over an arrow.

You have the following three options to connect the shape to other shapes: automatically connect to a nearby 

shape, create and connect to a new shape, or manually connect to any shape on the drawing page. 
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5.1. To automatically connect to a nearby shape, click on the blue arrow to confirm the connection. 

 

 
Figure 9 - Connecting to Nearby Shape 

5.2. To create and connect to a new shape, click on a shape from the pop-up.  

 

 
Figure 10 - Connecting to a New Shape 

 

5.3. To manually connect to any shape on the drawing page, drag the blue arrow to connect to a Glue 

Connection Point on the other shape, and then release. 

 
Figure 11 - Glue Connection Point 

 
Figure 12 - Connecting Manually to Another Shape 
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Modifying the Flowchart  

 

6. Altering a connecting line:  

 

6.1. Click on the connecting line to select.  

 

6.2. Move the Midpoint by dragging it on the screen. 

 

6.3. Release the Midpoint. 

Figure 13 - Selected Connecting Line 

 
Figure 14 - Modified Connecting Line 

7. Removing a connection: 

 

7.1. Click on the connecting line to select. 

 

7.2. Press the Delete key. 

 

 
Figure 15 - Removed Connection 
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8. Redirecting a connecting line to a different connection point: 

 

8.1. Click on the connecting line to select. 

 

 
Figure 16 - Selected Connecting Line 

8.2. Drag the Endpoint and align it with another connecting point of the shape.  

 

 
Figure 17 - Aligned Endpoint 

8.3. Release at the connection point. 

 

 
Figure 18 - Redirected Connection 
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9. Connecting to a different shape: 

 

9.1. Click on the connecting line to select. 

 

9.2. Drag the Endpoint and align it with a connecting point of a different shape.  

 

 
Figure 19 - Aligning Endpoint with Another Shape 

9.3. Release at the connecting point. 

 

 
Figure 20 - Connected to a Different Shape 
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10. Moving a shape:  

 

10.1. In the Pointer Tool mode, click the shape to select. 

 

 
Figure 21 - Selected Shape 

10.2. Drag the shape to a new location. The connector remains attached. 

 

 
Figure 22 - Moving Shape to the Left 

10.3. Release the shape at the desired location. 

 

 
Figure 23 - Moved Shape 
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11. Deleting a shape:  

 

11.1. Click on the shape to select. 

 

11.2. Press the Delete key. 

 

Modifying Shapes 

 

12. Formatting a Shape: 

 

12.1. Click on the shape to select.  

 

12.2. Use the ribbon tools in the Shape group, under the Home tab. 

 

 
Figure 24 - Shape Formatting Tools 

13. Editing the text in a shape: 

 

13.1. Double-click the shape. 

 

13.2. Enter the text. 

 

13.3. Click outside the shape to confirm text entry. 

 

 
              Figure 25 - Adding Text to Shape 
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14. Resizing a Shape: 

 

14.1. Click on the shape to select. 

 

14.2. Drag one of the sizing handles, and then release at the desired size. 

 

 
              Figure 26 - Resizing a Shape 

15. Rotating a shape: 

 

15.1. Click on the shape to select. 

 

15.2. Click and hold the blue dot above the shape. 

 

 
Figure 27 - Rotation Dot 

15.3. Rotate the shape, and then release at the desired angle. 

 

 
Figure 28 - Rotated Shape 
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Organizational Charts 

Creating an Organizational Chart 

 

1. Click on the File tab.  

 

2. Choose New. 

 

3. Select the Business template category.   

 

 
Figure 29 - Business Template Category 

4. Select Organization Chart. 

 

 
Figure 30 - Organization Chart Template 

5. Select Metric or US units. 
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6. Click on the Create button. 

 

Building the Organizational Chart 

 

7. Click and drag an Executive or Manager shape from the Shapes window and drop it onto the drawing 

page. 

 

8. While the shape is still selected, type the name and the title of the person. The page will zoom to 

100%. When done, click outside the shape to confirm the text entry. 

 

 
      Figure 31 - Organization Chart Shapes 

9. Drag and drop a Position shape on top of the Executive or Manager shape. The Position shape will be 

placed below the Manager shape, with a connector between the two. 

 

10. Drag and drop another Position shape onto the Manager shape. Any shape dropped onto another 

shape becomes subordinate of that shape. 

 

11. Continue the process until you have added all the necessary positions. 
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Note: There may be times when you need to manually connect two shapes. To do this, click the Connector 

Tool  on the ribbon, position the Connector Tool over one of the connecting points of a shape 

(indicated by an X), and drag to a connecting point of another shape. 

 

Manipulating Shapes 

 

 To format a shape, select the shape and use the ribbon tools in the Shape group, under the Home tab. 

 

 To edit the text on a shape, double-click the shape. 

 

 To resize a shape, select the shape and drag one of the sizing handles. 

 

 To move a shape, click and drag the shape to a new location. The connector remains attached. 

 

 To delete a shape, select the shape and press the Delete key. 

 

 To change the connecting point of a shape and a connecting line, click and drag the connecting line so  

that the end point of the line aligns with another connecting point of the shape. 
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Timeline 

Creating a Timeline 

 

1. Click on the File tab.  

 

2. Choose New. 

 

3. Select the Schedule template category.   

 

 
Figure 32 - Schedule Template Category 

4. Select Timeline. 

 

  

 

 

 

 

5. Select Metric or US units. 

 

6. Click on the Create button. 

 

Building the Timeline 

 

7. Click and drag a timeline style shape (Block, Line, etc.) from the Shapes window onto the drawing 

page.  

 

Figure 33 - Timeline Template 
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Figure 34 - Inserting a Timeline Style Shape 

The Configure Timeline dialog box opens. 

 

 
Figure 35 - Configure Timeline 

8. In the Time Period section, set the start and finish dates of the timeline. 

 

9. In the Scale section, select the unit of measure for the timeline. 

 

10. Click the Time Format tab and make any necessary changes. 

 

11. Click OK. 

 

Note: To change any of these settings later, open the Configure Timeline dialog box again by right-clicking 

the timeline, and then clicking Configure Timeline. 
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Figure 36 – Block Timeline 

12. Drag and drop a Milestone shape onto the timeline.  

 

The Configure Milestone dialog box appears. 

 

 
Figure 37 - Configure Milestone 

13. Set the date and time for the milestone. 

 

14. Enter a description for the milestone. 

 

15. Set the date format. 

 

16. Click OK. 

 

 
Figure 38 - Block Timeline with X Milestone 

Note: You can quickly change the date or time of the milestone by clicking and dragging the milestone 

marker to a new spot on the timeline. 
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17. Click and drag an interval shape onto the timeline. 

 

 
Figure 39 - Interval Shapes 

The Configure Interval dialog box appears. 

 

 
Figure 40 - Configure Interval 

18. Enter the interval information in the Configure Interval dialog box, and then click OK. 

 

 
Figure 41 - Block Interval on Timeline 

19. Modifying the Interval Shape 

 

19.1. Moving the interval: 

 

You can quickly change the interval by clicking and dragging the interval shape to a new spot on 

the timeline. 
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19.2. Moving the interval text: 

 

You can move the interval text off the timeline by clicking and dragging the yellow control handle in 

the center of the interval shape. 

 

     
Figure 42 – Yellow Control Button Appears on Selected Shape                  Figure 43 - Dragging the Yellow Control Button 

 

 
           Figure 44 - Text is Moved Off 

 

 
Figure 45 - Timeline with Text Off 

 

Modifying the Timeline 

 

You can edit any of the elements of the timeline by hovering the mouse pointer over that element,  

right-clicking, and selecting the appropriate item on the shortcut menu. 
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Saving a Diagram 

You can save your diagram as a standard Visio file (drawing) that you can share with other people who have 

Visio. In addition, there are many different formats that you can save your diagram in directly from the Save 

As dialog box. 

1. Click the File tab.

2. Click Save As, and then select a format in the Save as type list.

The different formats are useful for different ways of using or sharing your diagram. 

 Standard image file (including JPG, PNG, TIF, and BMP formats)

 Web page (htm format)

Note that image files and other resource files are saved in a subfolder of the location where you save

the HTM file.

 PDF

 AutoCAD drawing

Printing a Diagram 

1. Click the File tab.

2. Click on Print.

3. To print the diagram, click Print.

4. In the Print dialog box, do the following:

4.1. In the Name box, select the printer that you want (if it is not already selected). 

4.2. Under Page range, specify the pages in the drawing that you want to print. 

4.3. Under Copies, specify the number of copies that you want to print. 

5. Click OK when you are ready to print.


