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Introduction 

This tutorial covers creating and using a pivot table to extract different information from one data sample. 

This course will give you the skills to use a Pivot Table to produce meaningful analysis and charts from a 

simple table of information.   

Topics Include  

 Creating a Pivot Table 

 Analysing Data using Pivots 

 Filtering and Slicers 

 Creating a Pivot Chart Report 

 Working with multiple Values Areas 

 

Prerequisite 

Comfortable with Windows 7, or OSX 

Platform 

Windows, OSX 

Software 

Microsoft Excel 2013, Microsoft Excel 2010 (Windows) 

Microsoft Excel 2011 (MAC) 

Instructor  

Anna Neagu – Application Support Consultant 
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1. Pivot Tables 

 

When you have a lot of data, it can sometimes be difficult to analyze all of the information in your 

worksheet. PivotTables can help make your worksheets more manageable by summarizing data and 

allowing you to manipulate it in different ways. 

Using PivotTables to answer questions 

Suppose we wanted to answer the question: "What is the amount sold by each salesperson?" for the sales 

data in the example below. Answering this question could be very time-consuming and difficult—each 

salesperson appears on multiple rows, and we would need to total all of their different orders individually. 

We could use the Subtotal command to help find the total for each salesperson, but we would still have a 

lot of data to work with. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fortunately, a PivotTable can instantly calculate and summarize the data in a way that's both easy to read 

and manipulate. When we're done, the PivotTable will look something like this: 
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Once you've created a PivotTable, you can use it to answer different questions by rearranging, or pivoting, 

the data. For example, if we wanted to answer the question: "What is the total amount sold in each 

month?" we could modify our PivotTable to look like this: 

 

 

 

 

 

1.1. Create a Pivot Table 

 

Being able to analyse all the data in your worksheet can help you make better business decisions. But 

soŵetiŵes it’s hard to kŶoǁ ǁhere to start, espeĐiallǇ ǁheŶ Ǉou haǀe a lot of data. Excel can help you by 

recommending and then automatically creating PivotTables, which are a great way to summarize, analyse, 

explore, and present your data.  

 TIP: Make sure your data has column headings or table headers, and that there are no blank rows. 

1. Select the table or cells (including column headers) containing the data you want to use. 

2. From the Insert tab, click the Recommended Pivot tables.  

3. In the Recommended PivotTables dialog box, click any PivotTable layout on the left to get a 

preview to the right, and then pick the one that shows the data the way you want.  

4. Click OK. 

5. Excel places the PivotTable on a new worksheet and shows the Field List so you can further 

rearrange the PivotTable data as needed.  

 

Mac Users (2011) – Data tab / Create 

Automatic Pivot Table 
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To create a PivotTable 

1. Select the table or cells (including column headers) containing the data you want to use.  

2. From the Insert tab, click the PivotTable command.  

 

3. The Create PivotTable dialog box will appear. Choose your settings, then click OK. In our example, 

we'll use Table1 as our source data and place the PivotTable on a new worksheet. 

Mac Users (2011) – Data tab / Pivot Table 
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4. A blank PivotTable and Field List will appear on a new worksheet. 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Once you create a PivotTable, you'll need to decide which fields to add. Each field is simply a 

column header from the source data. In the PivotTable Field List, check the box for each field you 
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wish to add. In our example, we want to know the total amount sold by each salesperson, so we'll 

check the Salesperson and Order Amount fields.  

 

6. The selected fields will be added to one of the four areas below the Field List. In our example, the 

Salesperson field has been added to the Rows area, while the Order Amount has been added to 

the Values area. Alternatively, you can click, hold, and drag a field to the desired area. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. The PivotTable will calculate and summarize the selected fields. In our example, the PivotTable 

shows the amount sold by each salesperson. 
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 TIP: Just like with normal spreadsheet data, you can sort the data in a PivotTable using the Sort & 

Filter command in the Home tab. You can also apply any type of number formatting you want. For 

example, you may want to change the Number Format to Currency. However, be aware that some 

types of formatting may disappear when you modify the PivotTable. 

 

 

 

 

 

 

  

 

1.2. Refreshing the Data  

 

If you change any of the data in your source worksheet, the PivotTable will not update automatically. To 

manually update it, select the PivotTable and then go to Analyze Refresh.  

 

 

 

 

 

 

 

Refresh Data when opening a file 

There is an option that can be turned on that will refresh the data when opening the file. 

To set an option to automatically refresh PivotTable data when you open your workbook, do the following: 

1. From the PivotTable Tools click Options Tab then within Pivot Table Group, Options command. 

 

Mac Users (2011) – Same 

(Pivot Table Analyze Tab) 
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2. Click on the Data Tab and tick Refresh the data when opening the file  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click on OK. 

 

Mac Users (2011) – Same 

(Pivot Table Analyze Tab) 
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1.3. Pivoting Data 

 

One of the best things about PivotTables is that they can quickly pivot, or reorganize, data, allowing you 

to look at your worksheet data in different ways. Pivoting data can help you answer different questions 

and even experiment with the data to discover new trends and patterns. 

In our example, we used the PivotTable to answer the question: "What is the total amount sold by each 

salesperson?" But now we'd like to answer a new question: "What is the total amount sold in each month?" 

We can do this by simply changing the field in the Rows area. 

 

To change the row 

1. Click, hold, and drag any existing fields out of the Rows area. The field will disappear. 

2. Drag a new field from the Field List into the Rows area. In our example, we'll use the Month field. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. The PivotTable will adjust, or pivot, to show the new data. In our example, it now shows the total 

Order Amount for each month. 
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To add columns 

So far, our PivotTable has only shown one column of data at a time. In order to show multiple columns, 

you'll need to add a field to the Columns area.  

1. Drag a field from the Field List into the Columns area. In our example, we'll use the Region field. 

2. The PivotTable will include multiple columns. In our example, there is now a column for each 

region. 

 

 

 

 

 

 

 



  Excel Training - Level 3 

Page | 13 

 

1.4. Filters 

 

Sometimes you may want focus on just a certain section of your data. Filters can be used to narrow down 

the data in your PivotTable, allowing you to view only the information you need. 

 

To add a filter 

In our example, we'll filter out certain salespeople to determine how they affect the total sales. 

1. Drag a field from the Field List to the Filters area. In this example, we'll use the Salesperson field.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. The filter will appear above the PivotTable. Click the drop-down arrow, then check the box next to 

Select Multiple Items. 
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3. Uncheck the box for any items you don't want to include in the PivotTable. In our example, we'll 

uncheck the boxes for a few different salespeople, then click OK. 

 

 

 

 

 

 

 

 

 

4. The PivotTable will adjust to reflect the changes. 
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2. Grouping Data  

 

In the row and column label areas of a PivotTable report, you can group the items in a field in a custom 

way. Grouping the data can help you to isolate a subset of data that satisfies your specific needs, and that 

cannot be easily grouped in other ways, such as sorting and filtering. You may wish to group using one of 

the following:  

 Group numbers in numeric fields  

 Group dates or times  

 Group selected items  

 

To group fields 

1. Select the data In the PivotTable.  

2. Right-click on selected data, and click Group. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click OK. 
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To group by date 

1. Click any cell inside the Date column. 

2. Right click and click on Group. 

3. Select Months and click OK. 

 

 

 

 

 

 

 

 

 

4. The PivotTable will adjust to reflect the changes. 
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3. Pivot Charts  

 

Pivot Charts are like regular charts, except that they display data from a PivotTable. Like a PivotTable, a 

PivotChart is interactive. When you create a PivotChart, PivotChart filters are displayed in the chart area 

so that you can sort and filter the underlying data of the PivotChart report. Changes that you make to the 

field layout and data in the associated PivotTable are immediately reflected in the PivotChart.  

A PivotChart displays data series, categories, data markers, and axes just as standard charts do. You can 

also change the chart type and other options such as the titles, the legend placement, the data labels, and 

the chart location. 

 Just like regular charts, you'll be able to select a chart type, layout, and style that will best represent the 

data. 

To create a PivotChart 

In this example, our PivotTable is showing each person's total sales per month. We'll use a PivotChart so 

we can see the information more clearly. 

1. Select any cell in your PivotTable.  

 

 

 

 

 

 

 

 

2. From the Insert tab, click the PivotChart command.  

 

 

 

 

 

Mac Users (2011) – Not Applicable 
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3. The Insert Chart dialog box will appear. Select the desired chart type and layout, then click OK. 

4. The PivotChart will appear. 

 

 

 

 

 

 

 

 

 

 

 TIP: Try using slicers or filters to change the data that is displayed. The PivotChart will automatically 

adjust to show the new data. 

 

4. Slicers  

 

Slicers make filtering data in PivotTables even easier. Slicers are basically just filters, but they're easier and 

faster to use, allowing you to instantly pivot your data. If you frequently filter your PivotTables, you may 

want to consider using slicers instead of filters. 

When you use a regular PivotTable report filter to filter on multiple items, the filter indicates only that 

multiple items are filtered, and you have to open a drop-down list to find the filtering details. However, a 

slicer clearly labels the filter that is applied and provides details so that you can easily understand the data 

that is displayed in the filtered PivotTable report.  

 

To add a slicer 

1. Select any cell in the PivotTable. 

2. From the Analyze tab, click the Insert Slicer command.  

Mac Users (2011) – Not Applicable 

Mac Users (2016) – Same Tab 
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3. A dialog box will appear. Select the desired field. In our example, we'll select Salesperson, then 

click OK. 

 

 

 

 

 

 

 

 

 

4. The slicer will appear next to the PivotTable. Each selected item will be highlighted in blue. In the 

example below, the slicer contains a list of all salespeople, and six of them are currently selected. 
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5. Just like filters, only selected items are used in the PivotTable. When you select or deselect items, 

the PivotTable will instantly reflect the changes. 

 TIP: Try selecting different items to see how they affect the PivotTable. Press and hold the Ctrl key 

on your keyboard to select multiple items from a slicer. 

Slicers are typically associated with the PivotTable in which they are created. However, you can also create 

stand-alone slicers. A slicer typically displays the following elements: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Challenge! 

1. Open an existing Excel workbook.  

2. Create a PivotTable using the data in the workbook. 

3. Experiment by placing different fields in the rows and columns areas. 

4. Filter the report with a slicer. 

5. Create a PivotChart. 

 

 

 

 

1. A slicer header indicates the category of the 

items in the slicer.  

2. A filtering button that is not selected 

indicates that the item is not included in the 

filter.  

3. A filtering button that is selected indicates 

that the item is included in the filter.  

4. A Clear Filter button removes the filter by 

selecting all items in the slicer.  

5. A scroll bar enables scrolling when there are 

more items than are currently visible in the 

slicer.  

6. Border moving and resizing controls allow 

you to change the size and position  

 

1 

2 

3 

4 

5 

6 
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5. Timeline  

 

IŶstead of plaǇiŶg arouŶd ǁith filters to shoǁ dates, Ǉou ĐaŶ Ŷoǁ use a PiǀotTaďle tiŵeliŶe. It’s a ďoǆ Ǉou 
can add to your PivotTable that lets you filter by time, and zoom in on the period you want.  

Much like a slicer you create to filter data, you can insert a timeline once and keep it with your PivotTable. 

 

To create a timeline 

1. Click anywhere in a PivotTable to show the PivotTable Tools.  

2. Click Analyze and click on Insert Timeline.  

 

 

 

 

 

3. In the Insert Timelines dialog box, check the boxes of the date fields you want and click OK.  

 

 

 

 

 

 

 

 

5.1. Use a timeline to filter by time period  

 

With Ǉour tiŵeliŶe iŶ plaĐe, Ǉou’re readǇ to filter ďǇ a tiŵe period iŶ oŶe of four tiŵe leǀels (Ǉears, 
quarters, months, or days).  

1. Click the arrow next to the time level shown, and pick the one you want.  

Mac Users (2011) – Not Applicable 
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2. Drag the timeline scroll bar to the time period you want to analyse.  

3. In the timespan control, click a period tile and drag to include additional tiles to select the date 

range you want. Use the timespan handles to adjust the date range on either side.  

 

 

 

 

 

 

 

4. To clear a timeline, click the Clear Filter button.  

 TIP: If you want to combine slicers with a timeline to filter the same date field, you can do that by 

checking the Allow multiple filters per field box in the PivotTable Options dialog box (PivotTable 

Tools > Analyze > Options > Totals & Filters tab). 

 

5.2. Customize a timeline  

 

When a timeline covers your PivotTable data, you can move it to a better location and change its size. You 

can also change the timeline style, which may be useful if you have more than one timeline.  

1. To move the timeline, simply drag it to the location you want.  

2. To change the size of the timeline, click it, and then drag the sizing handles to the size you want.  

3. To change the style of the timeline, click it to display the Timeline Tools, and then pick the style 

you want on the Options tab.  
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6. Calculate values in a PivotTable report  

 

In PivotTable reports, you can use summary functions in value fields to combine values from the 

underlying source data. If summary functions and custom calculations do not provide the results that you 

want, you can create your own formulas in calculated fields and calculated items. For example, you could 

add a calculated item with the formula for the sales commission, which could be different for each region. 

The PivotTable report would then automatically include the commission in the subtotals and grand totals. 

 

6.1. Add a calculated field   

 

1. Click the PivotTable report. This displays the PivotTable Tools, adding the Analyze and Design tabs. 

2. On the Analyze tab, in the Calculations group, click Fields, Items, & Sets 

 

 

 

 

 

3. Click Calculated Field.  

 

 

 

 

 

4. In the Name box, type a name for the field  

Mac Users (2011) – Same Tab 
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5. In the Formula box, enter the formula for the field. To use the data from another field in the 

formula, click the field in the Fields box, and then click Insert Field.  

 

 

 

 

 

 

 

 

 

 

6. Click Add. 

7. Then click on OK.  
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6.2. Add a calculated item to a field  

 

In addition to the existing items in a pivot table field, you can create one or more calculated items. 

1. Click the PivotTable report. This displays the PivotTable Tools, adding the Analyze and Design tabs. 

2. On the Analyze tab, in the Calculations group, click Fields, Items, & Sets 

 

 

 

 

 

3. Click Calculated Item.  

 

 

 

 

 

 

4. In the Name box, type a name for the calculated item.  

5. In the Formula box, enter the formula for the item.  

 

 

 

 

 

 

 

 

Mac Users (2011) – Same Tab 
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 TIP: To use the data from an item in the formula, click the item in the Items list, and then 

click Insert Item (the item must be from the same field as the calculated item). 

 

6. Click Add.  

 

 

 

 

 

 

 

 

 

6.3. Value Field Settings  

 

Data in the Values area summarize the underlying source data (not the value that is showing) in the 

PivotChart report in the following way: numeric values use the SUM function and text values use the 

COUNT function. However, you can change the summary function. 

1. Select any cell in the PivotTable. 

2. From the Σ VALUES filed, click the Sum of option. 

3. Select Value Filed Settings. 

 

 

 

 

 

 

 

 

Mac Users (2011) – Same Options 
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4. Click the Summarize by tab. 

5. In the Summarize value field by box, click the summary function that you want to use.  

 

 

 

 

 

 

 

 

 

 

6. Click OK. 

 

 

 

 

 

 

 

 

 

 

7. PivotTable report compatibility issues 

 

Before you continue saving the workbook to an earlier file format, you should address issues that cause a 

significant loss of functionality so that you can prevent permanent loss of data or incorrect functionality. 
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Issues that cause a minor loss of fidelity might or might not have to be resolved before you continue saving 

the workbook—data or functionality is not lost, but the workbook might not look or work exactly the same 

way when you open it in an earlier version of Microsoft Excel. 

If you're a data analyst using PowerPivot to create data models in Excel, you might run into the following 

error if you share workbooks with colleagues who are using earlier versions of Excel. In its entirety, the 

error reads as: "This PivotTable was created in a later version of Excel and can't be updated in this version.”  

To update it, click OK, and then open the workbook in the version of Excel it was originally created in. 

In Excel 2013, data models are built into the software. If you upgraded an Excel 2010 PowerPivot 

workbook to Excel 2013, or created a new Excel 2013 workbook from the ground up that contains a data 

model, the workbook has limited backwards compatibility. You can open and view the workbook in Excel 

2010, but you won't be able to modify or manipulate PivotTables or PivotCharts.   

Within an organization, everyone using data models or model-based workbooks should run the same 

version of Excel, either using Excel 2010 with the PowerPivot add-in for Excel 2010, or upgrade to Excel 

2013 to use the embedded data model and data visualization features that are part of that release. 

 


