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Introduction 

This document has been developed to provide you with information about accessibility in Microsoft 

Office Excel 2016. In this document, you will learn about the tools available for accessibility. You will 

also learn how to control the visual appearance of your spreadsheet. Additionally, best practices and 

effective spreadsheet structure are also covered to help you when using Excel. 

 

Learning Objectives 

The following learning objectives for accessibility will be covered in this document. After completing 

the instructions in this booklet, you will be able to: 

 Utilize available accessibility tools 

 Use the keyboard to work with ribbon programs 

 Control the visual appearance of the spreadsheet 

 Understand best practices for spreadsheet design 

 Understand effective spreadsheet structure 

 Use the accessibility checker 

 Obtain help 
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Tools 

The following explains how various tools can be used effectively for accessibility with Microsoft Office 

Excel 2016. 

 

AutoCorrect 

The AutoCorrect feature in Excel 2016 is a list of words that are frequently misspelled and mistyped. 

This feature corrects these words when a person enters them into a document. The words can be 

added and deleted from the list. This is a great tool for accessibility. 

 

This tool can also be used for abbreviation expansion. For example, suppose that you frequently type 

Atlanta, Georgia, but would like to enter an abbreviation into AutoCorrect so that fewer keystrokes are 

required for entry. The following explains how to use the AutoCorrect tool for abbreviation expansion: 

 

 Click the File tab. 

 

 
Figure 1 - File Tab 

 The Backstage view will appear.  Click the Options button. 

 

 
Figure 2 - Options tab
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 The Excel Options window will open. Click the Proofing button. 

 

 
Figure 3 - Proofing 

 Click the AutoCorrect Options button. 

 

 
Figure 4 - AutoCorrect Options  
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 In the Replace box, enter an abbreviation for Atlanta, Georgia. For example, you could enter 

xATL(the x stands for expand). 

 

 
Figure 5 - Replace 

 In the With field, enter Atlanta, Georgia. 

 

 
Figure 6 - With Field  
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 Click the Add button. 

 

 
Figure 7 - Click the Add Button 

 Click the OK button to close the AutoCorrect window. 

 

 
Figure 8 - Click Ok  
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 Click OK to close the Excel Options window. When xATL is typed into Excel, the words Atlanta, 

Georgia, will appear on the screen.  

 

 
Figure 9 - Auto Correct 

 

Comments 

Comments are another tool that can be used for accessibility. The following instructions explain how to 

insert a comment: 

 

1. Place your cursor in the cell where the comment to be inserted. 

 

 
Figure 10 - Click the Cell 

2. Click the Review tab. 

 

 
Figure 11 - Click Review  
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3. Click on New Comment. 

 

 
Figure 12 - New Comment 

4. A comment box will appear. Enter a comment in the box that appears. 

 

 
Figure 13 - Enter a Comment 

5. When you have finished entering your comment, click on another cell in the spreadsheet to exit 

the Comment Box. 

 

6. To remove a comment, right-click on the cell containing the comment and then select Delete 

Comment. 

 

Spell Check 

The Spell Check feature in Excel 2016 allows you to double-check the sheet for spelling errors. To start 

a spell check, follow the steps below: 

 

1. Click the Review tab. 

 

 
Figure 14 - Click the Review Tab  
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2. Click the Spelling button. 

 

 
Figure 15 - Spelling Button 

3. The Spell Check tool will start and give you the option to accept or reject the suggestions 

offered. 

 

Thesaurus  

The Thesaurus is a great tool to improve the vocabulary used within the spreadsheet. To display the 

thesaurus, follow the instructions listed below: 

 

1. Place the cursor on your target word. 

 

 
Figure 16 - Placing Your Cursor 

2. Click the Review tab. 

 

 
Figure 17 - The Review Tab 

3. In the Proofing area, click Thesaurus. 

 

 
Figure 18 - Thesaurus  
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4. A window will appear on the screen showing other potential words that could be used in the 

place of the selected word. 

 

 
Figure 19 - Thesaurus Appears on the Right Side of the Spreadsheet 

5. To replace the word, hover your mouse over your preferred synonym.   

 

 
Figure 20 – Synonym 

6. Click on the drop-down located next to your preferred synonym.   

 

 
Figure 21 - Drop-down Menu 
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7. Click on Insert. Your synonym will replace the selected word.   

 

 
Figure 22 - Insert 

Templates 

The Template feature allows the user to have a spreadsheet available that has been customized with 

items such as name, date, etc. The background color, font style, font color, text size, etc. can be 

customized for the user as well.  

 

Note: Use Semantic Structure (or Styles) to create structure in Word, Open Office, HTML, etc. 

Heading 1 for Section Heading; Heading 2 for all Sub-Section Headings, ect. Also, Strong (structural 

equivalent of bold); Emphasis (structural equivalent of italics). Other Style types are available, as 

needed. Table of Contents should be provided based on the Heading structure; Table of Figures, if 

needed.  

 

Note: Ensure Readability by dividing large blocks of text into smaller more manageable sections, 

avoid complex sentences, and use sans-serif font at approximately 12 points.  

 

Note: Avoid Color Coding. Color alone is not a sole means of conveying important information.  

 

Note: Have Sufficient Color Contrast between foreground and background elements. Also, make 

sure the background does not overpower text (e.g. PowerPoint, Web page, etc.) 

 

To create a template, follow the instructions below: 

 Open a spreadsheet. 

 Enter any necessary text in the spreadsheet as desired. 
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 Apply your desired settings to the spreadsheet (e.g. background color, text size, etc). 

 

 
Figure 23 - Apply Spreadsheet Settings 

 Click the File tab.  

 

 
Figure 24 - File Tab 

 The Backstage View will open. Click Save As. 

 

 
Figure 25 - Save As  
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 Under Save As, select the Computer option. 

 

 
Figure 26 - Computer 

 Click Browse. 

 

 
Figure 27 – Browse 
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 In the File name field, enter the file name.  

 

 
Figure 28 - Save As 

 In the Save as type drop-down, select Excel Template. 

 

 
Figure 29 - Excel Template 

 Click Save. 

 

To open your Template:  

1. Click on the File tab. 

 

 
Figure 30 - File Tab  
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2. The Backstage View will open. Click New. 

 

 
Figure 31 – New 

3. In the New Excel document screen, click on Personal. 

 

 
Figure 32 - Personal  
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4. Templates that you have created will appear. Click on the template that you have created. 

 

 
Figure 33 - Click on Your Template 

 

Using the Keyboard to Work with Ribbon Programs 

Some users may prefer using the keyboard as they work with Microsoft Excel. Access Keys allow you to 

control each button on the ribbon with the keyboard. The following instructions explain how to use 

Access Keys: 

 

1. Press and release the Alt key on the keyboard. 

2. Letters and numbers will appear next to their corresponding buttons on the ribbon.  

 

 
Figure 34 - Letters and Numbers 

3. Press the corresponding number or letter of your choice on your keyboard. If you select a letter 

for one of the tabs on the ribbon, the tab will become selected and you will see a letter or 

number for each command on the selected tab.  For example, if we press the H key, you will be 

taken to the Home tab.  

 

 
Figure 35 - Pressing H Selects the Home Tab 
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Controlling the Visual Appearance of your Spreadsheet 

Excel 2016 has a number of features available to control the visual appearance of your document.  

 

Note: Ensure Readability by dividing large blocks of text into smaller more manageable sections, 

avoid complex sentences, use sans-serif font at approximately 12 points. 

 

Paint Bucket Tool 

The Paint Bucket tool allows you to draw attention to a certain part of the spreadsheet. The paint 

bucket tool can be found on the Home tab in the Font category. 

 

 
Figure 36 - Paint Bucket Tool 

Fonts 

You can determine what font you want included within your spreadsheet. The active font may be 

changed in the Font category under the Home tab. 

 

 
Figure 37 - Font 

The following fonts are considered easy to read: Arial, Verdana, and Helvetica. Fonts that are bold 

make the words appear larger. The Bold button is found on the Home tab in the Font category. 

 

 
Figure 38 - Bold Button 
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Font Color 

This tool gives you the ability to change the color of your text. You will find this tool on the Home tab in 

the Font category. 

 

 
Figure 39 - Font Color 

Note: Avoid Color Coding color alone is not sole means of conveying important information. 

 

Note: Sufficient Color Contrast between foreground and background elements. Also, background 

does not overpower text (e.g. PowerPoint, Web page, etc.). 

 

Cell Spacing 

Cell Spacing will increase/decrease the amount of space within a cell. The following instructions explain 

how to adjust the size of the cell: 

 

1. To increase/decrease the height of the cell, hover your mouse between the numbers on the 

left side of the spreadsheet so that it appears as a double-arrow. 

 

 
Figure 40 - Increase/Decrease height 

2. Click and drag your mouse up or down. This will change the height of the cell. 

3. To increase/decrease the width of the cell, hover your mouse between the letters on the top of 

the spreadsheet so that it appears as a double-arrow. 

 

  
Figure 41 - Increase/decrease width 

4. Click and drag your mouse to the left or right. This will adjust the width of the cell. 
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Zoom 

The Zoom tool magnifies the spreadsheet on the screen, and can be found on the View tab in the Zoom 

category. To change the zoom magnification: 

 

1. From the View tab, click Zoom.  

 

 
Figure 42 - Zoom 

2. Select your preferred Zoom Magnification. 

 

 
Figure 43 - Preferred Magnification 

3. Click OK. 

 

Note: This will not change the appearance of the spreadsheet when it is printed. 

 

Zoom to Selection 

The Zoom to Selection button can help to improve accessibility for users by increasing the size of text 

on the screen. The following explains how to use this feature: 

 

1. Select a cell on the spreadsheet. 

 

 
Figure 44 - Click on the cell 
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2. Under the View tab, click the Zoom to Selection button. 

 

 
Figure 45 - Zoom to Selection 

3. The spreadsheet will zoom to the selected cell. 

 

 
Figure 46 - Zoomed in Selection 

4. To return to the normal view, click the 100% button.  

 

 
Figure 47 - 100% Zoom 

Best Practices 

The following should always be considered when developing a spreadsheet to make it accessible to 

everyone. 

 

Page Layout 

Place the data on a spreadsheet so that it appears tightly connected together. It is best to avoid 

spacing data on the spreadsheet with blank cells, blank rows, and blank columns. 

 

Note: Ensure Readability by dividing large blocks of text into smaller more manageable sections, 

avoid complex sentences, and use sans-serif font at approximately 12 points.  
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Alternate Text (alt text) 

Be certain to use alt text for your graphics so that those with visual impairments will be able to 

understand the purpose of the graphics in the document. 

 

Note: Use Text Equivalents (ALT Text) for every non-text element such as image, chart or graph 

(e.g. A clear, concise description of 100 characters or less that is provided via Format Picture). If ALT 

text alone is insufficient, provide a Long Description in the surrounding text or as separate document. 

 

To add alt text to a graphic in Excel, follow the instructions below: 

 

1. Right-click the graphic. 

 

 
Figure 48 - Right Click on the Graphic 

2. A menu will appear. Select Format Picture. 

 

 
Figure 49 - Format Picture 
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3. The Format Picture window appears. Click the Size & Properties icon. 

 

 
Figure 50 - Size & Properties 

4. The Size & Properties options will appear. Click on ALT TEXT. 

 

 
Figure 51 - ALT TEXT 

5. The ALT TEXT window will open. Enter your title and description. 

 

 
Figure 52 - Title & Description 
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6. Click the Close button. 

 

 
Figure 53 - Close Button 

Note: Remember the following when developing alt text:  

 Use concise wording (do not exceed 100 characters). 

 Avoid sentences and capitalize only the first letter. 

 Avoid punctuation. 

 Avoid bold or italicized formatting. 

 

Font Size and Color Schemes 

Remember the following when developing spreadsheets so that they will be easily accessible. 

 Make all font sizes at least ten points. 

 Avoid using light or pale font colors with light backgrounds within a cell. 

 Limit the use of the following font variations: bold, italics, and capital letters. 

 

Note: Ensure Readability by dividing large blocks of text into smaller more manageable sections, 

avoid complex sentences, and use sans-serif font at approximately 12 points.  

 

Note: Avoid Color Coding. Color alone is not a sole means of conveying important information.  

 

Note: Have Sufficient Color Contrast between foreground and background elements. Also, make 

sure the background does not overpower text (e.g. PowerPoint, Web page, etc.). 
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Spreadsheet Structure 

The following explains how to better structure your spreadsheet for accessibility: 

 

Headings 

When developing the spreadsheet, be certain to use descriptive headings for rows and columns. Also, 

use headings for different sections of data on the spreadsheets. This will help people with screen 

readers to quickly and easily understand each section of the spreadsheet without having to read the 

details in each section. 

 

Note: Use Semantic Structure (or Styles) to create structure in Word, Open Office, HTML, etc. 

Heading 1 for Section Heading; Heading 2 for all Sub-Section Titles, ect. Also, Strong (structural 

equivalent of bold); Emphasis (structural equivalent of italics). Other Style types are available, as 

needed. Table of Contents should be provided based on the Heading structure; Table of Figures, if 

needed.  

 

Hyperlinks 

When inserting a hyperlink into a spreadsheet, the hyperlink will be more effective if the user sees a 

descriptive title for the URL. For example, if you have a link to Kennesaw State University in your 

spreadsheet, it would be more effective to use Kennesaw State University instead of non-descriptive 

text such as, Click Here. 

 

Note: Descriptive Hyperlinks must make sense out of context; avoid vague descriptions like Click 

Here or Email Me. Avoid using the URL. Instead, hyperlink text should describe the destination: website 

name, document name, or other resource. 

 

In Microsoft Excel, the hyperlink button is found on the Insert tab in the Links category.  

 

 
Figure 54 - Hyperlink 
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To insert a Hyperlink: 

 

1. Select the cell that you wish to add the hyperlink. 

 

 
Figure 55 - Select the Cell 

2. On the Insert tab, click the Hyperlink icon. 

 

 
Figure 56 - Hyperlink 

3. The Insert Hyperlink window will open. Click Existing File or Web Page. 

 

 
Figure 57 - Existing File or Web Page 
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4. In the Address field, enter the website that you wish to link to. 

 

 
Figure 58 - Address Field 

5. Click OK. 

 

 
Figure 59 - Click OK 

6. Your hyperlink will become active in the spreadsheet. 

 

 
Figure 60 - Active Hyperlink 

Graphs and Charts 

Users of screen readers will not be able to see graphs and charts created with Excel. Consider providing 

tables with words and numbers as an alternative.  When including a graph and/or chart on the 

spreadsheet, be certain that it is effectively labeled. 
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Sorting 

Often, it can be effective to organize and analyze data within the spreadsheet using the Sort feature. 

The following explains how to sort: 

 

1. Select the data to be sorted. 

 

 
Figure 61 - Selecting data 

2. On the Home tab, click the Sort & Filter button. 

 

 
Figure 62 - Sort and Filter 

3. The sort menu will open. Select your preferred sorting option. 

 

 
Figure 63 - Sort 
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Worksheets 

To make worksheets more accessible, it is important to give each sheet a meaningful name (the default 

names are Sheet1). In Figure 64, the worksheets have been renamed Customer Information. 

 

 
Figure 64 - Customer Information 

The following instructions explain how to rename the worksheet(s): 

 

1. Right-click on the Sheet 1 tab. 

 

 
Figure 65 - Sheet Name 

2. Click on Rename from the menu that appears. 

 

 
Figure 66 - Rename 
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3. The tab will become selected. Type the new name for the tab. 

 

 
Figure 67 - Customer Information 

4. Press the Enter key on the keyboard. 

 

Accessibility Checker 

The accessibility checker will scan your spreadsheet to check for potential accessibility problems. The 

following explains how to use this tool: 

 

Note: Accessibility Checkers always use the software's built-in Accessibility Checker (Word, Open 

Office, Adobe Acrobat, Excel, PowerPoint, etc.). Follow the Repair recommendations provided by the 

Accessibility Checker to fix errors. 

1. Click the File tab. The Backstage view will appear. 

2. On the Info tab, click the Check for Issues button. 

 

  
Figure 68 - Check for Issues 
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3. Additional options will appear. Click Check Accessibility. 

 

 
Figure 69 - Check Accessibility 

4. A report will be created for you containing a list of possible accessibility issues within your 

spreadsheet. Click an item to receive additional information on the issue.  

 

 
Figure 70 - Accessibility 

Additional Help 

For additional help or installation issues, please contact the KSU Service Desk: 

 

KSU Service Desk for Faculty & Staff 

 Phone:  470-578-6999 

 Email:   service@kennesaw.edu 

 Website:  http://uits.kennesaw.edu 

 

KSU Service Desk for Students 

 Phone:  470-578-3555 

 Email:   studenthelpdesk@kennesaw.edu 

 Website:  http://uits.kennesaw.edu 

mailto:service@kennesaw.edu
http://uits.kennesaw.edu/
mailto:studenthelpdesk@kennesaw.edu
http://uits.kennesaw.edu/
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