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Introduction

Microsoft Access allows people to effectively and efficiently organize data. This document has been
developed to show you how to use multiple tables and relational databases in Access 2016. The various
sections presented in this document will help you to build a solid knowledge foundation of the

software.

The Microsoft Access Booklet Series will provide you the necessary knowledge on how to use Microsoft
Office Access 2016. Before reading this booklet, it is recommended that you read the following Access
2016 documents on the UITS Documentation Center at http://uits.kennesaw.edu/cdoc:

e Microsoft Access 2016 — Intro to Access
e Microsoft Access 2016 — Intro to Forms

Learning Objectives

The following objectives are covered in this document:
* Understanding the concept of relationships as they relate to tables.
* Knowing how to define data types for relationships.
* Having the ability to create a relationship.
* Understanding relationships and forms.
* Knowing how to create a form for a two table relationship.
* Knowing how to create a tab form for a multi-table relationship.

Revised: 6/29/2016 Page 4 of 21


http://uits.kennesaw.edu/cdoc

Relationships and Tables

The power of Access is the software’s ability to create and maintain multiple tables. Access allows
multiple tables to work together thereby giving you strong database management capabilities.

Using Multiple Tables in the Access Database
Users of Access begin to utilize the full strength of the system when they use multiple tables to manage
data. For example, the following are two tables that could be used by a retail store that sells products

to customers.

Customer Information

Customer Number
First Name

Last Name
Address

City

State

Zip Code

Phone Number
Email

Purchases
Purchase I1D
Customer Number
Product Name
Quantity

Unit Price

Figure 1 - Two Tables

It would be ineffective to attempt to include all of the fields presented in Figure 1 in one table. Itis
much more efficient to create two tables and categorize the various fields within these tables.

An effective database used by a business, educational facility, governmental agency, etc. would

ultimately have many tables.
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Relationships Explained

When developing a database with multiple tables, it is important to understand relationships.
Relationships allow the different tables to communicate with each other. When creating different
tables, there must be one field that is common to the different tables. For example, Figure 2 shows
that the Customer Number field is common to both tables.

Customer Information

Eustomer Number '-'""-

First Name

Last Name

Address

City

State

Zip Code

Phone Number

Email

Purchases
Purchase 1D

Custormer Number

Product Name
Quantity
Unit Price

Figure 2 - Customer Number in two tables

Relationships and Data Types

When developing multiple tables, the Data Type for the common field will be defined differently in the

various tables.

For example, Figure 3 below shows that the Data Type for Customer Number is defined as AutoNumber
in the Customer Information table because this table is where the number is created. Notice that this

number is also the Primary Key.

Field Name [iata Type
%  customer Number AutoMumber
First Name Short Text
Last Name Short Text
Address Short Text
City Short Text
State Date/Time
Zip Code Short Text
Phone Mumber Short Text
Email Hyperlink

Figure 3 - Primary Key
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In the Purchases table, the Customer ID is defined as a Number. Also, notice that it is not defined as the
Primary Key.

EH customer Information |j Purchases
Field Mame Data Type
¥ D AutoMumber
Purchase ID Number
I customer Number Mumber I
Product Mame Short Text
Quantity Mumber
Unit Price currency

Figure 4 - Customer Number in the Purchases Table

How to Create the Relationship

The following explains how to create a relationship between two tables in Access.
1. Be sure both tables are closed before attempting.
2. From the Database Tools tab, click Relationships.

Home Create External Data Database Tools ’:_, Tell me what you want to do...

"';T IJ EF! D,E ’E :E-,: Database Documenter = ’EE ﬁ:

] ) ) - <™ Analyze Performance .
Compact and Visual Run Relationships Object Access SharePoint  Add-
Repair Database  Basic Macro Dependencies Database

Tools Macro Relationships Analyze IMove Data Add-Ins

=
&8 Analyze Table T

Figure 5 - Relationships

3. Inthe Show Table dialogue box, select each table and click Add.

Show Table ==

Tables | Queries | Both

formation

| sad | clos

Figure 6 - Click Add
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4. Both of the tables will be added to the Relationships window. Next, click the Close button in the
Show Table dialogue box.

. Relationships

Customer Information Purchases
7 Customer Numt_A': 7D

First Name Purchase ID

Last Name Customer Number

Address L Produd Name

City Quantity

state - unit Price

' = ~
Show Table =

Tables | Queries | Both
ustomer I i
PCHS\ .mf .“E'. :

[ Add J l Close l

Figure 7 - Click Close

5. Click to select Customer Number in the Customer Information table.

=% Relationships ",
Custorner Information Purchases
¥ Customer Nurrl - 71D

First Mame Purchase ID
Last Mame Customer Mumber
Address Product Mame
City Quantity
State - Unit Price

Figure 8 - Customer Number
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6. Hover your mouse over Customer Number in the Customer Information table and left-click your

mouse and hold. Drag over the Customer Number in the Purchases table and release.

:'1' Relationships

Customer Infformation

i CustomerNurrI s

First Name
Last Mame
Address
City

State

Purchases

71D
Purchaze [0

Customer Numbe

Product Mame

Quantity
Unit Price

Figure 9 - Creating the Relationship

7. The Edit Relationships dialogue box will appear. Click to select the box for Enforce Referential

Integrity and click the Create button.

Edit Relationships

2 o

Table/Query;

Custpmer Informat

Purchases

Cancel

Customer Nun‘!Zl Customer Numbe +

Join Type..

= Create New..
Ii_-l_’i Enforce Referential Integrity I ‘ Sii b

[T cascade Update Related Fields
|| cascade Delete Related Records

Relationship Type:

One-To-Many

Figure 10 - Enforce Referential Integrity

What happens when you enforce referential integrity?
1. Ifthe record doesn’t exist in the primary key field of the primary table, it can’t be
entered in another related table.
2. The record can’t be deleted from the primary table if there is a record that relates in
another related table.
3. The primary key number cannot be changed in the primary table if there is a record
that relates to it in another related table.
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8. The relationship will be established.

:'-; Relationships

Customer Information Purchases

¥ Customer Muml| = 1 ¥ ID
First Mame _\_ Purchase ID
Last Mame — Customer Mumber
Address Product Mame
City Quantity
State - Unit Price

Figure 11 - The Relationship is established

9. Click the Close button to exit the Relationship Tools screen. When prompted, click Yes to save
the relationship that you created.

- Relationship Tools

Home Create External Data Database Tools

D‘F' X Clear Layout D == Hide Table 0

57 Direct Relationships|

=l [5] Relationship Report ~ 2hOW i . Close
Relationships et Tahle EEEAIIREIatmnshms

Tools Relationships

Figure 12 - Close Button

Relationships and Forms

There are many different ways to develop forms when you have relationships among different tables
established. The following are some popular design techniques.

Creating a Form for a Two Table Relationship

The following is an example of how to develop a form for a two table relationship. For example, you
may need multiple table forms in the event you have a database that contains more than one table.
The tables within the database are Customer Information and Purchases.

All Access Obje... @ «
Search. p

Tables *

j Customer Information
j Purchases

Figure 13 - Tables to create the form
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1. Create a form using the Form Design tool for the Customer Information table.

?_:;'| Customer Form

Figure 14 - Form for Customer Information Table

Note: For more information on creating Forms, refer to the documentation Microsoft Access 2016:
Intro to Forms at https://uits.kennesaw.edu/cdoc.

2. On the Design tab, click the More button for additional controls.

-

Imcommandershepard : Databas...

Form Layout Tools 2 - [} x
Home Create External Data Database Tools Arrange Format Q Tell me what you want to do... Evan Atkin
A n =l Logo DD
Fal Colors = Prany E
. Aa D = [ Title o
View  Themes [4]Fants - D T Add Existing Property
. . FoDateandTime  Ficlds  Sheet
Views Themes

Contrals Header / Footer Tools

Figure 15 - The More Button

3. Click the Subform/Subreport button.

s BBl Aa =] [ €3 Eel B [ ;
NEEOVWE I ® r

Figure 16 - Subform/Subreport

I

Ir"
pn
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4. Draw a box on the form for the Purchases table.

Customer Number

First Name

Last Name

R
Address
Lo L

City
F
Zip Code
Phone Number n

Figure 17 - Purchases Table Form

5. The Subform Wizard will appear. Click Next.

SubForm Wizard

Tou canuse an 2xstng form to oeate your subform or subreport, or
create your own using fables andfor quenes.

‘What data would you like to use for your subform or subreport?

(@ 1iJse esing Tables and Uueries

Cancel Bacl Next >

Figure 18 - Click Next
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6. Click to select the table that you want to place on the form.

SubForm Wizard

Which fields would you like to incude on the subform or subreport?

You can choose fields from more than one table and/or query.
Tables/Queries

lrable: Purchases] El h

Available Fields:

Selected Fields:
jin]

Purchase ID
Customner Number .
Product Mame “:]
Quantity

Unit Price

Cancel l | < Badk H Mext = J [ Finish

Figure 19 - Subform Wizard

7. Click the double-arrow button to add all of the fields onto the subform that you are creating.

Available Fields: Selected Fields:

Purchase ID
Customer Mumber
Product Mame

Quantity
Unit Price

Figure 20 - Sub form Arrow

8. Click the Finish button.

Tables/Queries

Table: Purchases

[=]

Available Fields: Selected Fields:

jin}

Purchase ID
Customer Mumber
Product Name

[ Cancel H < Back ][ Next > “ Fish |

Figure 21 - Click Finish

Page 13 of 21



9. The Purchases subform will appear on the Customer Information form.

Customer Number §

First Mame

# Form Header
¥ Detail

Figure 22 — Subform

10. You may now enter data in both the form and subform.

Customer Number §i
First Name Andraw

Last Name Wilson

Address 1232 Shaw Rd
City Tallahassee
State
Zip Code 3

Phone Number 555-555-5555

=3
=)
i

Email awilson@ksu.edu

D = | Purchase ID - Customer Nu - Product Name Quantity -
1 22 1 Desk Chair 55

2 33 1 Desk Lamp 12

(New) a 1 ]

Record: M

Figure 23 - Entering Data
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Creating a Form with Tabs for a Multi-Table Relationship

The following explains how to create a form with tabs for a multi-table relationship. Forms with tabs
are necessary in the event that you need to enter data into a database with multiple tables.

1. Create the necessary tables for the database. In this example we will need tables for an

insurance company database. Figure 24 illustrates a database that has tables for:

e Customer Information
e Autoinsurance
e Life insurance

e Property insurance.

All Access Obje... @ «
Searchi..
Tables
EH AutoInfo

»b

j Customer Info
j Life Insurance

j Property

Figure 24 - Tables for an Insurance Database

2. Create a relationship for all of the tables in the database shows an example of relationships

created for a database for an insurance company.

Life Insurance

Auto Info

% Vehicle Number

Customer Info

¥ Customer Number

# Life Number
Customer Mumber
Amounted Insured
Date Insured

Customer Mumber First Mame

Auto Make Last Name

Auto Model City
State

Property

¥ Home Mumber
Customer Number
Home Value

Figure 25 - Relationships for the Database

3. Create forms for all of the tables EXCEPT for the main table. For example, you would create

forms for Auto, Property, and Life.
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Create the Main Form for your Customer Info Table

1. Create a form for the Customer Info table using the Form Design tool.

Note: For more information on creating Forms, refer to the documentation Microsoft Access 2016:

Intro to Forms at https://uits.kennesaw.edu/cdoc.

2. Apply any color/labels/formatting to your form.
3. On the Design tab, click the Tab Control button.

-

Imcommandershepard : Databi

Home Create External Data Database Toaols Arrange Format

A olors © kY
5 o] Beer e 4= [Ce BB = -

Views Themes Controls

@ Tell me what you want ta d

1 ]

E,E' Logo

[ Title

F{l} Date and Time
Header / Footer

Figure 26 - Tab Control Button

4. Draw the Tab Control onto the Form.

Paga2e | Pagead

Figure 27 - Draw Tab on the form
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5. To add more tabs, right-click over one of the tabs and click Insert Page from the drop-down
menu (See Figure 28).

6. To delete a tab, right-click over one of the tabs and click Delete Page from the drop-down
menu (See Figure 28).

Build Event...

&% Cut
By Copy
Tﬁ Paste

7] InsertPage ‘

%4 Delete Page

Page Order...

ES Tab Order...

Figure 28 - Insert and Delete Page

7. Torename the tab, click to select the tab.
8. From the Design tab, click Property Sheet.

o Imcommandershepard : Database... Farm

Home Create External Data Database Tools Arrange Format @ Tell me what you want to

= |
D nCoIors' ~ D G- 0G0 DD = 0=
..... e =
) s Bbl Aa =] 7] &3 el F - ) Tice =
View  Themes Foms' G2 —| Insert ) Add Existing] Property | Tab
- - Image ~ 3 Date and Time Fields Sheet JOrder &
Views Themes Controls Header / Footer Tools ~

Figure 29 - Access Property Sheet
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9. The Property Sheet will open. On the Format tab in the Caption category, enter the name of the
tab.

Property Sheet x

Selection type: Page

Pagel& |E|

Format | Data | Event | Other | A |

ICaptinn Customer Informatio
Page Index [i]

Visible Yes

Picture Type Embedded

Picture [none)

Width 410427

Height 344797

Top 0.7917"

Left 1.09358"

Figure 30 - Renaming Tabs

10. From the Design tab, click Add Existing Fields to add the fields onto the tab for this main form.

- Imcommandershepard : Database... Form Design Tools

Home Create External Data Database Tools Arrange Format Q Tell me v

il ogo Cog

D Aa ECDIDrsY S - D & . DD o=
. 2] L5 bl Ag =[] & F=] (5 - [ Tike CE =
View  Themes Fonts' D - Insert o ] g
- Image - “® Dateand Time Fields Sheet  Order &

Views Themes Controls Header / Footer Tools -~

Figure 31 - Add Existing Fields

11. In the Field List window that appears, click Show all tables.

Field List x

IE- Show all tables Ih

Figure 32 - Show all Tables

12. Click the “+” for the name of the main table containing the fields that you want to add. For this
example, you would click the “+” for Customer Info.

Customer Info Edit Table

Figure 33 - Expanding the Table
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13.

14.

Drag the fields from the Field List onto the tab that you have selected.

=5] Form1',

# Detail

Customer Information | Page27

i
Customer Number BCustomer Num
IFirs‘t Mame First Name
lCiw City
lSTaTe State

Figure 34 - Main Tab

[]] *

Field List x

Ig Show only fields in the current record source

Fields available for this view:
= Customer Info Edit Table
Customer Mumber
First Name
Last Name
City
State

You are now ready to add the forms that you created earlier to the other tabs. Click to select
the tab where you want to add your form.

Customer Information | Page27

Figure 35 - Select the Tab
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15. From the Design tab, click More.

v Imcommandershepard : Databas...

Home Create External Data Database Tools i Format Q Tell mew t you want to do... Ewvan Atkin

j il Logo

D Aa nColorsv T fo LOG DD .

_ %Aa . @l 5 [ Title - =l

View  Themes Fonts* D H Insert ) Add Existing Property
- - * mage 5% Date and Time Fields Sheet

Wiews Themes Controls Header / Footer Tools ~

Figure 36 - The More Button

16. Select the Subform/Subreport control.

L bl Ag =[]

A

x| |
=

vVia | ®17]

Figure 37 - Subform/Subreport

7
o[
[

17. Draw a box on the form for the selected tab.
18. The Subform Wizard dialogue box will appear. Select the option Use an existing form
(See Figure 38).
19. A list of forms in your database will appear. Select the form of your choice (See Figure 38).

SubForm Wizard

' You can use an existing form to aeate your subform or subreport, or
reate your own using tables andjfor queries,

What data would you like to use for your subform or subreport?

() Use existing Tables and Queries

(@) Use an gxisting form «

Auto Form
Life Insurance Form
Property Form

[one ] o0 [0 ] [ow

Figure 38 - Subform Wizard

20. Click the Finish button.
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21. The Auto Form will be added inside the Tab Control. Use the sizing handles around the form to

adjust the size.

Customer Information | Auto Information

Auto Form

»

Recard: M < [Lofl | » M » | E noFilier |[Search <] [v]

Figure 39 - Subforms

22. Repeat steps 14 — 21 to add the remaining subforms.

Additional Help

For additional support, please contact the KSU Service Desk:

KSU Service Desk for Faculty & Staff

e Phone: 470-578-6999
e Email: service@kennesaw.edu
e Website: http://uits.kennesaw.edu
KSU Student Helpdesk
e Phone: 470-578-3555
e Email: studenthelpdesk@kennesaw.edu
e Website: http://uits.kennesaw.edu
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