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Introduction

Microsoft Office Access 2016 allows people to effectively and efficiently organize data. This document
has been developed to help you learn more about several useful features in Access including printing,
applying queries, and importing Excel files. The various sections presented in this document will help
you to build a solid knowledge foundation of the software.

The Microsoft Access Booklet Series will provide you the necessary knowledge on how to use Microsoft
Office Access 2016. Before reading this booklet, it is recommended that you read the following Access
2016 documents on the UITS Documentation Center at http://uits.kennesaw.edu/cdoc:

e Microsoft Access 2016 — Intro to Access
e Microsoft Access 2016 — Intro to Forms
e Microsoft Access 2016 — Relational Databases and Subforms

Learning Objectives
The following objectives are covered in this document:

e Creating reports and labels.

e Placing calculations on reports.
e Using the query feature.

e Importing an Excel file.
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Creating a Report

When you use a database, you typically use reports to view, format, and summarize data. The
following explains how to create a report in Access.
1. From the Create tab, click Report Design.

External Data Database Tools Q Tell me what you want to do...

ﬁ D G D ’TI m E D F‘&FormWizard i- ] i @Repor‘c‘.’\'izard

- ) & Mavigatian ~
Application  Table Table SharePoint Query Query  Form  Form  Blank ReportjReport] Blank Labels
Parts - Design  Lists~ Wizard Design Design Form More Forms ~ DesignfiReport
Templates Tables Queries Forms Reports

Figure 1 - Report Design

2. You will be brought to the Report Design view. Right-click over the Page Header bar.

ﬁkeporﬂ..
| | AR R g e eme ten)kox a2 Gax el G G683 B Ul D o eor e gsr o o8B e gopp o ooos - g

"€ Detail

Figure 2 - Page Header

3. Select Report Header/Footer.

Build Event...

" [(£ Sorting and Grouping

%S Tab Order...

‘[3 Paste

D Fill/Back Color |»
Ruler

Grid

-0

Page Header/Footer
Report Header/Footer 1

s,
- BATA

=1

Report Properties

[ [

Properties

Figure 3 - Click Report Header/Footer
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4. The following explains the different areas available in the Report Design.
a.

Report Header — Text placed here will appear on the top of the first page of the report.
For example, if there are ten pages in the report, the text would only appear at the top

of the first page (See Figure 4).

Page Header — Text placed here will appear at the top of every page. Use this for

column headings and page numbers (See Figure 4).
Detail — Text placed here will appear on every page (See Figure 4).

Page Footer — Text placed here will appear at the bottom of every page. Use this for
footers and page numbers (See Figure 4).
Report Footer — Text placed here will appear at the bottom of the last page of the
report. This is a perfect place to put an End of Report statement (See Figure 4).

ilﬂRepom
™ A ST R X

¥ Report Hesde

& Page Header

& Detall

& Page Footer “

¥ Report Footer

Figure 4 - Report Design
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section bar. As you do this, a double-arrow will appear.

# Report Header

& Detail

# Page Footer

I l I

& Report Footer

Figure 5 - Adjusting the Size of Report Sections

5. You can resize different areas of the report sections. Hover your mouse over the top of a

When you see the double-arrow, hold down the mouse button and move your mouse to

make the section larger or smaller.

You can also adjust the width of the report. Hover your mouse over the right edge of the

report. As you do this, a double-arrow will appear.

& Report Header

# Detail

& Page Footer

s [

¥ Report Footer

l

Figure 6 - Adjusting the Width of the Report

make the report larger or smaller.

8. When you see the double-arrow, hold down the mouse button and move your mouse to
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Adding Labels to a Report
Labels can be used to place text in the different areas of the report. Adding a label to your report is
similar to adding one to a form. The following explains how to add a label to a report:

1. Onthe Design tab, in the Controls grouping, click Label.

H = Eo.' O ﬂrtor' I Report Design Tools Databaser : Database- C:\Users\eatkil

File Home Create External Data Database Tools Arrange Format Page Setup Q Tell me what you want to do...
7 0y s, |
- | Bl colors - | Uaizs h A B Xvn || D E o

- - . a - D > Title
View  Themes B Group 1= Hide Details \ —| Insert Page )

- - 2] & Sort Image~ MNumbers [5% Date and Time

Views Themes Grouping & Totals Controls Header / Footer

Figure 7 - The Label Button

2. Your cursor icon will change to display the Label icon. Hold the left mouse button and drag to
draw a text box on the form.

fg Reporti

‘Repnrt Header

Figure 8 - Drawing your Text Box

3. Once finished drawing your text box, release the left mouse button. Your text box will appear.
4. Click in the text box and type your text.

f Report Header

Figure 9 - Entering Text into the Text Box
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Change Text Style and Color
To change the text style and color of text:
1. Select the text you want to format.

Figure 10 - Selecting your Text

2. From the Home tab, the text can be formatted using the tools found in the Text Formatting
grouping.

Form Design Toals

tz Design Arrange Forrmat Q Tell me...
D % Calibri (Detail) - -
Em B I U
Wiewy o
. 4 X Delete ~ A~ - ===
“iews  Clipboard Sort & Filter Records Find Text Formatting -

Figure 11 - Text Formatting Tools

Move and Resize a Text Box
The following explains how to move and resize a text box:
1. Click on the text box to select it.
2. Hover your mouse over the side of the text box. The cursor will turn to a crosshair with arrows.

# Report Header
T

# Page Header

Figure 12 - Hovering your Mouse to the Side of the Text Box

3. Hold left click and move the text box to the location of your choice on the form.
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4. To re-size the text box, hover over a sizing handle, then hold left click and drag the mouse to

resize the text box.

eader

# Report H
Seasssssazes tessses: T

& Page Header

Figure 13 - Anchor Points on the Text Box

Adding Fields to the Form

In order to display data from your database in a report, you will need to add the fields from an existing
table first. This process is similar to adding fields to a form. The following explains how to add fields to

a report:
1. From the Design tab, click the Add Existing Fields button.

H = FG | § - - Report Design Toals Databese? : Database- CilUsersheatkintDoc...

File Home Create External Data Database Tools Arrange Format Page Setup Q Tell me whet you want to do...

fom | [ sl i}
- i Siel= i+l Logo — 1)

; Ag] Bcoos- o=t 1S bl Ag =1 [T] &, [ - 2 [a) = B | E =
- - o " (223 _ Iy
View  Themes I'llFonts- GIOUP 335 Hide Details ~> (=] [ - Insert Page Fbp o Add BostingfFroperty  Tab :E

= = 8 Sort Image - Mumbers o Date and Time Ficlds Sheet  Order
Wiews Theme: Grouping & Totals Cortrols Header / Footer Tools

Figure 14 - Add Existing Fields

2. The Field List window will appear. Click Show all tables.

Field List x

I [ showall tables I

Figure 15 - Show all tables

3. Click the + next to the table that contains the fields that you want to add to your form.

Field List x

E’ Show only fields in the current record source

Fields available for this view:
I Student Inforrmation Edit Tahlel

Figure 16 - Adding Fields
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4. A list of fields will be displayed. Left-click and hold on the first field you wish to add, then drag

5.

your mouse to the form.

E Reportl

Field List x

# Report Header EY Show only fields in the current record
source

L T e T R O

Fields available in other tables:
B Student Information

Customer Number

First Name

Edit Table

Last Name
City
State

Figure 17 - Adding Fields

When the field is over the form, release your mouse button and the field will be added to the
form.

6. Repeat steps 4 and 5 until all desired fields have been added to your form.

Arranging Fields on the Report
Once the fields have been added from a table in your database, they will need to be arranged properly.

The following instructions explain how to quickly arrange the fields on the report.

1.

Select all of the fields that you want to arrange on the report by left-clicking and dragging your
mouse cursor over all fields.

When you release the mouse button, all of the fields that were contained in the selection box
will be selected.

From the Arrange tab, click Tabular.

H i Eﬁ" O ﬂrtor’ - - Report Design Tools Database?

File Home Create External Data Database Tools Design Format Page Setup Q Tell m
Select Layout
o Select Column ) -
Gridlines StackedTabularRemove Insert Insert Insert Insert B Merge  Split Split Move Maove
Layout ~Above Below Left Right Select Row Vertically Horizontally Up Down
Table Rows & Columns IMerge / Split Mowve

Figure 18 - Stacked Layout

Page 11 of 32



4. The selected fields will be arranged in a Tabular layout, with the labels appearing in your report
header, and the fields lining up underneath.

¥ Page Header
Fi

.......... ST Y

moerneirsy

F Detajl

usto

Figure 19 - Tabular Layout Applied to Fields

5. From the Arrange tab, click Remove Layout.

H il E&" O !rtor! - - Report Design Tools Database?

File Home Create External Data Database Tools Design Farmat Page Setup Q Tell m
Select Layout
==l ] —| - —
Select Column

Gridlines Stacked TabularfRemove] Insert Insert Insert Insert - Merge  Split Split Mave Move
Layout | Above Below Left Right Select Row Vertically Horizantally Up Down
Table Rows & Columns Merge / Split Move

Figure 20 - Remove Layout Button

6. The fields will be neatly arranged on the form. You can now move the fields around
individually if you need to organize further.

7. Decrease the vertical space in the Detail section.

# Report Header

# Page Header

# Report Footer

Figure 21 - Adjust Vertical Section

Note: The area displayed in the detail section will be displayed for each record in your report. A larger
vertical area in the Detail section results in the records being further apart on the report.
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Adding Page Numbers to Your Report

Adding page numbers to your report will help others track their position while reading through the
data. The following explains how to add page numbers to a report:
1. From the Design tab, click Page Numbers.

H il EO:‘ 0 EQ# — Report Design Tools Database’ : Database- C:\Users\eatki

File Home Create External Data Database Tools Arrange Format Page Setup Q@ Tellr

j nCoIorsv -._ ZTctals % AG m »@c m >|—| - D

. _ L |
View  Themes Fonis~ Group TEl Hide Details D —| Insert Page )

- b . & Sort Image ~ |Numbers “5 Date and Time
Views Themes Grouping & Totals Controls Header / Footer

Figure 22 - Page Numbers

The Page Numbers window will open. Under Format, select a number format (See Figure 23).
Under Position, select the location for the page numbers to be displayed (See Figure 23).
Under Alignment, select an option from the drop-down (See Figure 23).

Click OK (See Figure 23).

vk wnN

8 X -
Page Numbers &lﬁ
s

@ Page N
©) Page Nof M
Position

@) Top of Page [Header]
(") Bottom of Page [Footer]

Alignment:

Center [z]

[7] sShow Number on First Page

Figure 23 - Page Numbers: Format

6. Your Page Numbers will appear in the selected position.

T
i|Customer Numbe First Name

¥ Page Footer

Figure 24 - Page Numbers Added to Footer
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Saving your Report

The following explains how to save the report.
1. Click the File tab.

HEED& @ -

Report Design Tools
File Haome Create External Data Database Tools Arrange Farmat Page Setup
; )
T [ Mo B 3 —
. ~ Aa = [0 &) [ = -
View  Themes Fontx" Group i Hide Details (] — Insert
- - & Sort Image ~
Views Themes Grouping & Totals Controls

Figure 25 - File Tab

2. The backstage view appears. Click Save.

Figure 26 - Click Save

3. The Save As window appears. Enter a name for the report and click the OK button.

o e o
Save Az m

Report Mame:

Sales Repart]

==

Figure 27 - Saving the Report

Note: It may help you stay organized if you name the report the same name as the table that the

report is associated with.
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4. To close the report, click the X in the upper-right area of the report.

Create

BExternal Data

Database Tools

Format

Home

View  Themes Fonts'

Views Themes

All Access Obje... @ «

S2arcin
Tables
Queries
Forms

WA W b

Reports

; A

i- | ECDIUrs' [ 2 Totals
Group {5 Hide Details
& Sort

Grouping & Totals

Eﬂ Sales Report *,

Arrange

Q Tell me whaty

| [ &

Page Setup

D TR TR

# Report Header

A XYL ||
%Aaljl%un—l;lnsert |-_"ElgeF|
Image~ Numbers =
Controls
x
1 1 L3 1 4 1 v 6o [

4 Distail

Viewing your report

Figure 28 - Closing the form

Once your report has been set up, you can view it at any time. If you add more records to your
database, they will automatically be included on your report every time it is viewed. To view the
report, simply open the report from under your Access Objects and the report will appear on your

screen.

Eﬂ Sales Report ',

1

2

Sales Report

Customer Number Last Name

Vaughn
Norman
Christensen
Norman

Byrd

First Name

Harlon

Rita

Jill

Rita

Asa

City
Hempstead
Tulsa
Dallas
Chicago

Houston

State
California
Minnesota
California

MNew York

Texas

Figure 29 - Report View
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Printing a Report

You can print out a copy of your report to present as a handout. All formatting that is present on the
form will carry over to your printout. To print the report:

1.

2.
3.
4

Under All Access Objects, select a report you wish to print.
From the Home tab, click File.

The backstage view will open. Click Print.
The Print options will display. Click Print.

Quick Print
Send the object directly to the default printer without making
changes.

Print

Select a printer, number of copies, and other printing options
before printing.

Account

Options

Print Preview
Preview and make changes to pages before printing.

Figure 30 - Print

5. The Print window will appear. Select a printer to print your report to, and click OK.
6. The report will be sent to the selected printer.

Creating Mailing Labels Using a Report

If you have a list of mailing addresses in your Access database, you can create a report that will
generate labels based on the information found in your database. To create the mailing labels:

1. Select the table containing the data that you will use to create your labels.

All Access Obje... @ «

Search. yo
Tables A
:j Auto

Ij Customer!nformation"

B ife
;_j Property
Reports

»

§= Reservation Report

Figure 31 - Select the Table
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2. From the Create tab, click Labels.

H E&" 0O !r:?’ — Database7 : Database- C:\Users\eatkin\Documents\Database7 .accdb (Access 2007 - 2016 file format) - Access
File Home External Data Database Tools Q@ Tell me what you want to do...
L, = i 5 : 5 e
D Lj D D‘:\ L’j Lﬂg D & Form Wizard E @ D 3] Report Wizard 2E Madule
— . e ) e e [E] Navigation - %! Class Module

Application  Table Table SharePoint Query Query Form  Form  Blank Report Report Blank Labels Macre )

Parts = Design  Lists = Wizard Design Design Form More Forms - Design Repor =] Visual Basic
Templates Tables Queries Forms Reports Macros & Code

Figure 32 - Labels

3. The Label Wizard window appears. Under Product Number, select the label code provided by
the label manufacturer (e.g. Avery) and click Next.

Label Wizard

This wizard creates standard labels or custom labels.

What label size would you like?
imensions: Number across:

1 (2 1/2" 3
11/2"x 39/10" 2
1 1/4" x 7 31/50" 2
2°x 2 3
112 x 112" 4

/000000000000000000

TIRTATAI

0000000000000000000

Unit of Measure Label Type
(@ English (7) Metric @) Sheetfeed ) Continuous
Filter by manufacturer: ;:Aver_y E
Customize... [} Show custom label sizes

Figure 33 - Label Wizard

4. A list of formatting options will appear. Make any desired adjustments to the formatting
options and click Next.

Label Wizard

What font and color would you like your text to be?

Text appearance
Font name: Font size:
rial Greek _ 1B [+
Text color:
[~] I -]

[ Italic [ Underline

[ cancel | [ <Back | mext> |

Figure 34 -Formatting Options
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5. Alist of available fields from the selected table will display. Under Available Fields, select a
field, then click the arrow button to move fields over to the Prototype label field.

Label Wizard

/

What would you like on your mailing label?

Construct your label on the right by choosing fields from the left. You may also
type text that you would like to see on every label right onto the prototype.

Available fields: Prototype label:
| = l
| First Name [
|Last Name =
Ioos
| City =
|State
| Cancel ji < Back }[ Next > ]| Finish

Figure 35 - Adding Fields to the Prototype Label

6. Repeat step 5 until all desired fields have been added under Prototype Label. Click Next.

Note: When adding fields, be sure to account for spacing and punctuation between your fields.
Fields added one after the other without spacing or punctuation will display all information from
the table as one long string of text.

7. Alist of available fields is displayed for you to sort your labels on. If you would like to sort
the data, select a field under Available fields, then click the arrow to move the selected field

in to the Sort by column.

Label Wizard

-
59065000000

di

You can sort your labels by one or more fieldsin your database. You might
want o sort by more than one field (such as last name, then firstname), or by
just one field (such ac poctal code).

Which fields would you like to sort by?
Availzble fields: Sortby:

Customer Number

Last Name

[ cancel | [ <Back | Next> | [ Fnish

Figure 36 - Sorting Results

8. Continue sorting fields until you are finished, then click Next.
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9. Inthe next window, enter the name for the report and click the Finish button.

Label Wizard

Whatname would you like for your report?

Labeks Information

That's all the information the wizard needs to create your labels!

Whatdo you want to do?
(@) See the labels as they will look printed.
(7 Modify the label desian.

[(Cancel | [ <Bok | 1=

Figure 37 - Name Label Form

10. The report will be created and saved under your list of Access Objects.
11. To print the labels, see the section Printing a Report.

Placing Calculations on a Report

Reports can also be set up to display information that is not found on a table. For example, you could
create a field that calculates the total sales between two days. The following sections will explain
how to place a calculation on a report by first setting up the report with a new text box field for the
total sales, then how to create the calculation.

Adding a New Calculation Field to a Report
The following explains how to place a calculation on a report by first setting up an existing report with
a new text box field for the total sales.

1. Onthe Design tab, click the Text Box.

H s E‘:‘ O Eor‘ - - 2P esi 5 Database’ : Database- C:\Users\eath
File Home Create External Data Database Tools Arrange Format Page Setup Q Tellm
- I8 Logo
:| Ecoors~  pld 3 rotas A [] g | = JDTIQ
e .- - itle
View  Themes Zl Fonts - Group fEl Hide Details M a o T . Insert Page §
M M & Sart Image~ Numbers “© Date and Time
Views Themes Grouping & Totals Controls Header / Footer

Figure 38 - Text Box
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2. Draw a text box in the Detail section of the report.

& Page Header

Store Number || Location

3. After entering the text box, click the label to select it.

Figure 39 - Drawing a Text Box

& Detail

Store Number Location

{pay1

Unbound

Figure 40 - Select the Label

4. Right-click the label. A context sensitive menu will appear.

5. Click Cut.

cu
&=¢

E® Copy

Change To
Tab Order...

‘EJ Paste

e

Figure 41 - Click Cut

6. Right-click inside the Page Header section

7. Click Paste.

Figure 42 - Paste the Label into the Page Header Section
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8. Drag the label over the corresponding text box in your form.

& Page Header

Storé Numberrq 7L0cation

Figure 43 - Align the Label with the Text Box

9. Enter a descriptive name for the label.

& Page Header

T

l:‘Store Number |:ii|Location

Figure 44 - Enter Total Sales into Label

10. Select the text box.
11. From the Design tab, click Property Sheet.

H = F':' [} h_?’ - = Repart Decign Tool: Databaced : Databace- C:'Users\eatkin'Doc. ..

File Home Create External Data Database Tools Arrange Format Page Setup Q0 Tell me what you want to do...

T T N el ogo
D ‘@ B colars - L > Tatals [:\\3\ Ag [+ D % |}(\'Z ‘H . j B LD 'Il_'itlge DD %5 ©
- roperty

View  Themes m [Femig= Group i3 Hide Details — Insert Fage ) Add Existing X
- & Sort Image~ MNumbers E_‘“J Date and Time Fields Sheet  |Order ‘T:!

WViews Themes Grouping & Totals contiols Header f Fooler Tools

Figure 45 - Click Property Sheet

12. On the Property Sheet, in the Other tab, enter a descriptive name in the Name field.

1 Property Sheet 2

Selection type: Text Box
[ Textd B B

[Format| Data | Event { Other § au |

Name —’lTotal Sales
Datasheet Caption

ControlTip Text |
Tab Index 4
Tab Stop Yes

Status Bar Text
Shortcut Menu Bar

Help Context Id 0
Vertical No
Tag

Figure 46 - Enter a Name for the Text Box
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Using the Expression Builder to Create a Calculation

The following explains how to set-up the calculation on a report by using the Expression Builder.
1. Onthe Property Sheet, in the Data tab, click the ellipsis in the Control Source field.

Property Sheet *

Selection type: Text Box

Total Sales E]
Formal Data QEvent IOther| All I

Control Source EEI

Text Format Plain Text
Running Sum No

Input Mask

'Enabled Yes

Figure 47 - Control Source

2. The Expression Builder will open. In the Expression field, type = to begin a formula.

Expression Builder i g 1 @
Enter an Expression to create a calculated control:
(Examples of expressions include [field1] + [field2] and [field1] < 5)
= ok ]
<< Less
Expression Elements Expression Categories Expression Values
f&l Store Sales [<Report> A .
@ Functions <Field List> || | AfterDelConfirmEmMacre—
Kolsoy Salsiacadh <Parameters> _ ||| AfterFinalRenderEmMaa—
o Y % Auto_Logo0 = || | AfterInsertEmMacro
i ] Constants Auto_Header0 ||| AfterLayoutEmMacro
B4 Operators Auto_Date AfterRenderEmMacro
@ Common Expressions Auto_Time AllowDesignChanges
Labeld AllowFilters
Label1l AllowLayoutview
Label2 AllowReportView
Label3 ~ || AlternateBackShade e

Figure 48 - Expression Builder

3. Enter the formula as [Day 1] + Day 2].

Expression Builder

Enter an Expression to create a calculated control:
{Examples of expressions include [field1] + [field2] and [field1] < 5)

= [Day 1] + [Day 2] 4

<< Less

Hil

Figure 49 - Enter the Formula

4. Click OK to close the Expression Builder.

Page 22 of 32



5. On the Property Sheet, in the Format tab, select Currency from the Format field.

Property Sheet x
Selection type: Text Box
Day1 EJ

Data | Event [ Other | An |

1
Format
Decimal Places AUTO i
Visible Yes
Width 04167
Height 0.2188"
Top 0.0417° ‘
Left 24583°
Back Style Normal
Back Color Background 1

Figure 50 - Select Currency for the Data Type

6. The calculation has been created. You will see the new field and the results of your calculation
when in the Report View.

Store Number Location Day 1 Day 2 Total Sales
2|/ sandy spring | $20,000.00 || $15,000.00 $35,000.00
3|| Athens $12,000.00 $18,000.00 $30,000.00
4| Kennesaw ‘ $16,000.00 $17,000.00 S33,GG0.00>
5|| Atlanta-Midtown $30,000.00 $25,000.00 $55,000.00
6 || Atlanta-Candler Park | $24,000.00 || $17,000.00 $41,000.00 |

Figure 51 - Calculations for Total Sales Complete

Creating Queries

Queries can be set-up to help you to search through a database for specific information, and then
saved so they can be run multiple times. Some examples of items that can be searched for include:
e Stores with sales above or below an indicated amount
e Students earning an “A” in a specific course
e People who live in a specific zip code
e Companies located in a specific state

e Employees who have completed a First Aid course
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The following explains how to create a query to search for stores in the database that had sales above
$700 on the first day of a special sale that was held by the company.

1. From the Create tab, click Query Design.

Home Database Tools Q Tell me what you want to do...
it = i ; : ;
==l = EEREEEER T
- ) Navigation'
Application  Table Table SharePoint Query jQuery § Form  Form  Blank Report Report Blank Labels
Parts - Design  Lists ~ Wizard |Design Design Form Il More Forms - Design Report
Templates Tables Queries Forms Reports

Figure 52 - Query Design

2. The Query Design view will appear with the Show Table window, displaying a list of tables.
Select the table that you want to add and click Add.

Show Table LR
| Tables | Quenies | Both | ‘
Store Saes — | |
|
l
|
[cuee
Figure 53 - Show Table
3. Click Close.
4. Inthe Query Builder at the bottom of the screen, place your cursor in the first column of the
Field dropdown.

[»

B
Field: :l
|

Table:
Sort:
Shows: ] E ] [ [
Criteria:
or

Figure 54 - Query Builder

5. Click the dropdown, and select the field that you want included in this query.

]

UL Store Sales. [NES
AELIEE Store Sales.*
Sort: || Store Number
Show: j Location
Criteria:
or:

Figure 55 - Selecting Field for the Query
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6. Repeat steps 4-5 for the other columns, until you have all of the fields listed that you want

included in this query.

Field:}ll Store Sales.* | Location Day 1
Table: [Store Sales ore Sales ' Store Sales
Sort:
Show: 72 [ ] [

Criteria:
or

]

-

Figure 56 - Building Out the Query

7.
you want to perform the search.

you would enter the following in the sort row: >=700.

In the Criteria row, enter what you are searching for in the database under the field where

For example, if you wanted to search for stores that had sales $700 and higher on day 1,

Field: |Store Sales.* Location Day1
Table: |Store Sales | Store Sales Store Sales
Sort:
Show: ] & ‘ V] ‘ ]
Criteria: | >=700 |

or

Figure 57 - Entering Your Search Criteria

8. From the Design tab, click Run.

- -

H o ED

File Haome Create External Data Database Tools

Cluery Tools

:

Database

Tell n

s IO s ESTIE PV BNGEE I Nl i

View | Run Select rake Append Update Crosstab Delete EE::-;:i:Lilt?:n Show

- able == Table

Results Query Type
Figure 58 - Run the Query
9. The results of your query will be displayed.

Store Numb ~ Store Sales.l ~ Store Sales.l ~ Day2 -~ Fieldo ~ Field1 ~
E Sandy Spring $20,000.00 $15,000.00 Sandy Spring $20,000.00
3 Athens $12,000.00 $18,000.00 Athens $12,000.00
4 Kennesaw $16,000.00 $17,000.00 ' Kennesaw $16,000.00
5 Atlanta-Midtoy $30,000.00 $25,000.00 Atlanta-Midtoy $30,000.00
6 Atlanta-Candle  $24,000.00 $17,000.00 Atlanta-Candle  $24,000.00
* (New) $0.00 $0.00 $0.00

Figure 59 - Query Results
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Saving your Query

The following explains how to save the query.
1. Click the File tab.

E i E’:‘ D ‘rg‘ - - Report Design Tools
Hame Create External Data Database Tools Arrange Farmat Page Setup
- )
O Huee Bree puo o w e ) O
View  Themes Fontx" Group i3 Hide Details a o 1 —| Insert
- - & Sort Image ~
Views Themes Grouping & Totals Controls

Figure 60 - File Tab

2. The backstage view appears. Click Save.

Figure 61 - Click Save

3. The Save As window appears. Enter a name for the query and click the OK button.

Save As | ? P
Query Name:
Store Sales
QK ] [ Cancel
b "l

Figure 62 - Saving the Form

Note: Any data that is entered into the table after the query is saved will be included in the query if it
meets the criteria specified.
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Including a Query in a Report

The following explains how to include the results of a query in a report.
1. From the Create tab, click Report Design.

E ] EO:' D EQF' Database? : Database- C\Users\eatkin\Documents\Databasel .accdb (Access 2007 - 2016 fil

File Home External Data Database Tools Q@ Tell me what you want to do...

D LE D ’TI m E m D B j . j {7l Report Wizard

avigation ~

. : E Navig

Application  Table Table SharePoint Query Query  Form  Form  Blank Reportf Report | Blank .Labels
Parts ~ Design  Lists~ Wizard Design Design Form =] More Forms - Design JReport

Templates Tables CQueries Forms Reports

Figure 63 - Report Design

2. From the Design tab, click Property Sheet.
3. Onthe Data tab of the Property Sheet, click the drop-down arrow for Record Source.

Property Sheet "

Selection type: Report

Report E]

]Formatl Data | Event | Other | Al

Record Source EE]
Filter

Filter On Load No

Order By

Order By On Load Yes

Allow Filters Yes

Figure 64 - Set Record Source

4. A list of your tables and queries will display. Select your query from the list.
5. Proceed as normal designing the report. The data that appears on the report will come from
the query that you selected.

Importing an Excel File into Access

If you already have data stored within an Excel spreadsheet, you can import that information into an
existing table, or create a new table with the information. The following explains how to import data
from an existing Excel spreadsheet and create a new table within Access.

1. From the External Data tab under the Import & Link grouping, click Excel.

D \rtor’ - Database7 : Database- C:\Users\eatkin\Documents\Database7 accdb (A
Home Create Database Tools Q Tell mewhat you want to do...

| ﬂ E]?Text File !3 B [J . E]Access

LE T LE" i g g g
? -’ 2 @—“, XML File @ Word Merge
Saved Linked Tablq Excel Jccess ODBC - Saved Excel XML PDF  Email ,_ -

Imports Manager Database | 5 More~ Exports Flle File orXPS More~

Import & Link Export

Figure 65 - Import Excel File
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2. The Import Spreadsheet Wizard will appear. Click Browse.

Select the source and destination of the data

Specfy the source of the definition of the objects,

Eilename:  CUsers\kwil368\Documents), W

Spacfy how and where you want to store the datainthe current database.

@ Import the source data into a new table in the current database.

If the specified table does not exist, Access will areate it If the specified table already exists, Access might oververite its
contents with the imported data, Changes made to the source data will not be reflected in the database,

Append a copy of the records to the table:  ctore S5las

If the specified table exists, Access will add the records to the table, I the table docs not exist, Access will areate .
Changes made to the source data will not be reflected in the database.

Link to the data source by creating a linked table.

Access will areate a table thet will maintain a link to the source data in Excel. Changes made to the source data in Excel will
be reflected in the linked table, However, the source data cannot be changed from within Access,

Cancel

Figure 66 - Browse for External Data

3. The File Explorer will appear. Select the Excel file to import and click Open.
4. Select the Import the source data into a new table in the current database option.

5. Click OK.

Specily how and whnere you want to store the data in the current database,

)

Import the source data into a new table in the current database,

If the specified teble does not exist, Access will create it, T the specified table already exists, Access might overwrite its
contents with the imported data. Changes made to the source data will not be reflected inthe database

! Append a copy of the records to the table: Siore Saes

i the specified table exists, Access will add the records to the table, If the table does not exist, Access will craate it.
Changes made to the source data will not be reflected in the database.
Link to the data source by creating a linked table.

Access will create a tablz that will maintain a link to the source datz in Excel, Changes made to the source data in Excel will
De refiected In the linked table, However, the source ¢ats cannct be changed from within Access.,

Figure 67 - Import the Source Data into a New Table
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6.

Note: If your Excel file only has one spreadsheet, then skip to step 7.

If the Excel file contains multiple spreadsheets, select the spreadsheet and click Next.

E Import Spreadsheet Wizard

@ Show Worksheets
() Show Named Ranges

‘Your spreadsheet file contains more than one worksheet or range. Which worksheet or range would you like?

TEF
| Region Total

|

Sample data for worksheet 'Detailed sales_ MA'.

1 Balesperson Customer Rddrezsz City Erate Phone -
?’aughn, Harlon B&E Spaces [7583 Balsam Hempstead California [(369) 50 _
?Norrﬁan, Rita Home US4 10370 Walnut [ulaa Minnesota (552} 58
TChIistensen, Jill Ellington Designs [14743 Chaton [Dallas California ((887) 58
?NOIIGE.TL, Rita Ellington Designs [11951 Butternut [Chicago Hew York (548) 83
?Syrd, L=a ELE Spaces Q629 Locust Houston [exas {3486} B3
Zl}wen, Robert Ellington Designs MS935 Fir [ucson California ((356) 64

R = b

e

Figure 68 - Multiple Spreadsheets Available

7. The wizard will ask you if the first row of your spreadsheet contains column headings. If yes,

check the box next to First Row Contains Column Headings.

8. Click Next.

Microsoft Access can use your calumn headings as field rames fer your table, Dozs the first

row spadfied contain column heedings?

[V Frst Row Corntains Calumn Headings

First Name

Last Name

Custcmer Numbar

48 Ken fmith »
2P Phazcn ook
3B i ke Exyant
B Rmanda Elliot Rcworth
15p Busan Bllen FKennssaw
< r
i Cancel I | Next = Finish

Figure 69 - First Row Contains Column Headings
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9. For the next step of the import wizard, you can select the different columns and adjust the
Field Name and Data Type for the database.

You can spacify information about each of the fielcs you are importing. Select fields in the area balow. You can then modify fisld

information in the 'Field Opticns' area.
Field Optons
Field Names Data Type:  Couble [l
Index=d: m | Do not impart field (Skip)
Cuatomer Number |Firs Last Nawe |City
Fmith Pcworth
Cook Kennesaw
Bryant Ma t
Elliot BCWorth
pllen Kennesaw
‘ Cancel ] < Back [ Mext > i Enich i

Figure 70 - Adjust Field Options

10. When you are finished, click Next.
11. Determine if you want Access to create a primary key for you, if you want to choose your own
primary key from data within the spreadsheet, or if you don’t want a primary key.

(o

L NETE R
2 xR weR
. uxn wwe wwn
CASTERE R
LR

Microsoft Access recommends that you define a primary key for your new table. Aprimary key is usad to
uniquely identfy each record in your table. It allows you to retrieve data more quickly.

) Let Access add primary key.

"'Customer Number |w

Last Name |City

Pmith RBcworch
Hennesaw
Mariecta
Rcworth
Kennezaw

12. Click Next.

Figure 71 - Add Primary Key
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13. The wizard will ask you to enter a name for the new table in the Import to Table field.

That's al the information the wizard needs to import your data,

Import to Table:
Customer Information|

[7] 1 would like & wizard to analyze my table afier importing the data.

[ Cancel j[ <Back ]

Figure 72 - Import to Table

14. Click Finish.

15. The Save Import Steps window will appear. Select Save Import Steps if you wish to save the
import steps. Doing so will allow you to quickly repeat the operation.

Save Import Steps

Finiched imparting file 'C\Users\kwill368\Desktop\Report Book.xlix' to tabie ‘Customer Information'.

Do you want to save these import steps? This will allew you te quickly repeat the operation witheut using the wizard.

: Save import steps

16. Click Close

Figure 73 - Save Import Steps
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17. The information in Excel will be imported into Access. At this point, you can create forms,

create reports, create queries, etc.

l j Customer Information

Customer NI ~ | First Nrame v
Ken
2 Sharon
3 Mike
4 Amanda
5 Susan

Last Name ~
Smith
Cook
Bryant
Elliot
Allen

City
Acworth
Kennesaw
Marietta
Acworth
Kennesaw

v |Click to Add  ~

Figure 74 - New Table Imported

Additional Help

For additional support, please contact the KSU Service Desk:

KSU Service Desk for Faculty & Staff

e Phone: 470-578-6999
e Email: service@kennesaw.edu
e Website: http://uits.kennesaw.edu

KSU Student Helpdesk

e Phone: 470-578-3555
e Email: studenthelpdesk@kennesaw.edu
e Website: http://uits.kennesaw.edu
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