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Excel 2016: Large Data 1 - Sorting and Filtering
1.5 hours

In this workshop we will work with single and multilevel sorting; learn to use data
filters to automatically show only the specified data set; and do math on our
filtered data sets. This workshop also contains a very brief introduction to other
summary tools such as Subtotal and Pivot Tables. This intermediate workshop
assumes prior experience with Microsoft Excel.
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Sorting Data
On the far right side of the Home tab you will find a large Sort & Filter

button. The menu you see when you click on the button is reflected in
the Sort & Filter group of the Data tab.

If you make a selection of cells, Excel will think you only want to sort or
filter by that selection. But if your
dataset has no blank rows and no
blank columns Excel will see the
whole range as one data set.

Sort & Filter

[¥] Fill =
& Clear~

Ed

2 AutoSum ~ A
o O

Sort & Find &
Filter = Select ~

it 4] SortAtoZ
Zl sertZtoa

J Custom Sort...
T

You can have blank cells, but not completely blank columns/rows; if
you are not sure that your dataset is consistent, click inside one cell, and press Ctrl-A. This will select all
the cells within the dataset. A second "Ctrl-A", or pressing the shortcut in an empty cell, will select the

entire sheet.

When you have completed a sort, you can click the Undo button (or Ctrl-Z). Excel will undo the sort and
it will select the dataset it used in the sort. This is another way to see your dataset.

Ascending Sorts
- Text: Sort alphabetically from Ato Z A B £
1 Apples 123 1/1/1971
- Numbers: Sorts from smallest number to largest number Tl ananas 456 2/2/1982
- Dates: Sorts from the newest date to the oldest date aillcherries 789 3/3/1993
Descending Sorts
- Text: Sort alphabetically from Z to A A_ 8 <
1 Cherries 789 3/3/1993
- Numbers: Sorts from largest number to smallest number Ml ananas 456 2/2/1982
- Dates: Sorts from the oldest date to the newest date 3 |Apples 123 1/1/1971

Custom Sorts

When you first open this window, Excel will show the most recent sort options. If you haven't created a

sort yet, this window may be blank.

.

0% )

Sort
+a E: .
7| Add Level x Delete Level 2 Copy Level Options... |:| My data has headers
‘ Column Sort On Order
Ll Column A E'I Values IE‘I AtoZ IEH

Then by | Column B E‘ |values IE‘ Smallest to Largest IE‘
Then by |column ¢ E‘ Values Iz‘ Oldest to Newest Iz‘
QK ] | Cancel

| %

In Excel 2016, we can sort by 64 levels. From this sort window we can add levels, delete levels, copy
levels, and even change the order of our sort using the up and down arrows in the toolbar.
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Column: The column drop-down menu will show the names of your columns, your 'fields'. If your data
doesn't have titles Excel lists the column heading letters instead. If you were expecting titles, but is only
showing the column letters, you can click on the check box in the upper right hand corner of the Sort
window to let Excel know your data has headers.

Sort On
Sort On: You can Sort on the values of the cells, the cell colors, the font | Values E
colors, or the cell icons. Values
Cell Color
. ) ) Font Colar
Order: The order options change depending on the values in the cells. Cell Icon
Text Number Date
Crder Order Order
AtoZ |E| Smallest to Largest E Cldest to Newest E
AtnZ smallest to Largest iOldest to Newest
oA Largest to Smallest Mewest to Cldest
Custom List... Custom List... Custom List...
Font Color Cell Color
Order Order
onTop [+ No Cell Color |+ | (OnTop =]
Automatic Mo Cell Color
I N . [ |
Custom Lists
Custom I|§ts can be built t.hrough the (R B x|
Excel Options under the File menu in
the Advanced section under General.
. - . Customn fists: List entries;
Or by choosing Custom List... option at =
the bottom of each order box above. oo, Mo e, Wed TR 6L, 3t
Sunday, Monday, Tuesday, Wedne:
Jan, Feb, Mar, apr, May, Jur, Jul, A
i i i Januar?r. February, March, }_\pril. Me
If you choose this option, you will be Shopping, Peanut butter, pickles, pr
able to select from one of these lists.
Alphabetically, April comes before I
January. With the Custom List order, we =
can ensure January comes first' Press Enter to separate list entries.
These custom lists will work as patterns
with the fill handle. Notice the
"Shopping" list? Once | set this up, | can [ o cancel

type any of the words in a cell and use
the fill handle to follow this pattern.

Sort Options

- Case sensitive: Sort lowercase letters before uppercase letters

- Orientation: Sort vertically (top to bottom, sort rows) or horizontally

(left to right, sort columns)

[ Sort Options | IQ |Q@

Crientation

@ Sort top to bottom
_- sort |eft 1o right

0K Cancel




Filtering Data ¥ AutoSum * %‘T p
Filters hide rows (records) based on criteria you set. You can turn the filter on Fill - - .
and off by choosing Filter from the Sort & Filter button on the Home tab, or Edear”  Hiter= select -
choosing the Filter button on the Data tab. b
Excel will place a drop-down arrow at the end of each cell in the title row T
(the first row of the dataset). When you click on this arrow we see several Y Rt
options including our sort orders:
e Sort Ascending, Descending, and by color
o C(lear the Filter _ :
e Filter by Color 2 Y _ __'m
£2 heapply
e Set a custom filter (text, number, date) Filter
W‘ Advanced
e Search for a matching value in the column .
Sort & Filter
[ ]

List of values in the column (field). Select All will toggle
between everything and nothing.

Once a filter has been set Excel will hide all the rows that don't match the criteria. The status bar will
show how many records (rows) were found that matched. The row numbers of the original data will
remain the same, but will appear blue. The dropdown arrows of the columns that are being filtered will
show the filter icon (funnel). The double line between the row numbers indicate hidden rows.

H o

& -

SortCustomersxlsx - Excel O

Insert Page Layout Formulas Data Review View Q Tell me what you want t¢ Signin ‘Q_Share
X Calibri -11 | = ==FE General - Conditional Formatting ~ Insert ~ | 2 ~ 27~
Eg- B I U- A A ===~ $-% » EPFormatasTable- BxDelete ~ [#]- O~
Paste - &H-A- =x & 90 [ Cell Styles - [E1format~ &
Clipboard & Font 5 Alignment & Number Styles Cells Editing ~
D1 - Je CITY v
A B C D E F -
1_LLAST - |FIRST - ADDRESS v|CITY [ 19T - |ZIP -
3 Appleton April PO Box456 %l sotAtoz L 32689
31 fatz Kerry PO Box 3346 £l sotzioA FL 32689
62: hores Susan PO Box 5592 Sort by Color » FL 32689
ks : Y Clear Filter From "CITY"
79 |
80 | Text Filters 4
81 | Search jo,
82 v
83|
84
85
86
87 |
88
] oK ] l Cancel -
[Sheet1 | @ g
Rem = o = 1 + 130%




Custom Filters

Depending on the data in the column you will have the option to set a custom filter based on text,

numbers, and dates.

Text Filters
Equals...
Does Not Equal...

Begins With...
Ends With...

Contains...

Does Not Contain...

Custom Filter...

If you choose one of the options on the Filter List with the ellipsis (...), you
will see a Custom Auto Filter window such as this. From here we can set up

to two filters.

Number Filters
Equals...
Does Not Equal...

Greater Than...

Greater Than Or Equal To...
Less Than...

Less Than Or Equal To...

Between...

Top 10...
Above Average

Below Average

Custom Filter...

-

Custom AutoFilter

L‘EJ \_& |

Show rows where:
BALAMNCE

equals

©) and

-]

Use ? to represent any single character
Use * to represent any series of characters

l

rom—  E——

-

Date Filters
Equals...

Before...
After...

Between...

Tomorrow
Today
Yesterday
Next Week
This Week
Last Week
Next Month
This Month
Last Month

Next Quarter
This Quarter
Last Quarter

MNext Year
This Year

Last Year
Year to Date
All Dates in the Period »

Custom Filter...

Be careful with the AND/OR relationships. If you ask Excel to show the rows where the City equals
Jacksonville AND the City equals Gainesville, you will get no results, because one cell cannot equal both
values. But if you ask for the same using the OR, Excel will show all the records for both cities. Or's tend
to work for exact matches (Equals This OR Equals That), whereas AND's tend to work for ranges (Greater

than This AND Less than That).

You can use the "Wildcards" ? and * to help you with your filter. ? is used for one character, * for

multiple.

Equals Jacks* -> Jacksonville, Jacksonville Beach, Jackson Heights

Some of the filter choices may work just as well. | could say Contains 'Jacks' or Begins with 'Jacks'.




SUBTOTAL Worksheet Function

We can do common mathematical functions with our filtered lists using the SUBTOTAL worksheet
function. The syntax is for this function is "SUBTOTAL(function_num,refl,ref2,...)". Function_num is the
number 1 to 11 that specifies which 'function' to use in calculating subtotals within a list (see below).
The refl, ref2... are the ranges of data that should be used in the equation, there can be up to 29
different ranges used in this function.

Function_Num Function Function_Num Function
1 AVERAGE 7 STDEV
2 COUNT 8 STDEVP
3 COUNTA 9 SUM
4 MAX 10 VAR
5 MIN 11 VARP
6 PRODUCT

Function numbers 1 through 11 will include manually-hidden rows, ones you have hidden yourself.
Function numbers 101-111 will exclude your hidden rows from the function. Filtered-out rows are
always excluded.

A B Iz D E F
1 [Sum 1411 SubSum 1411
2 |Average 8.70987654 SubAvg 8.70987654
3 |Count 162 SubCount 162
4
5 |Quarter ~ | ltem - | Size ~ | Color - | # Sold -
6 |1st Quarter blouses Large Blue 14
T |1st Quarter blouses Large Red 3]
8 |1st Quarter blouses Large White 10
9 |1st Quarter blouses Medium Blue 2
10 |1st Quarter  blouses Medium Red 4
A B Iz D E F
1 |Sum 1411 SubSum 24
2 |Average 8.70987654 SubAvg 3
3 |Count 162 SubCount 3
4
5 |Quarter |-T|ltem | Size ~ | Color - # Sold -
43 |2nd Quarter pants Large Red 3
46 |2nd Quarter pants Medium Red 3]
49 |2nd Quarter pants Small Red 10
168
169
A B Iz D E
1 [Sum =SUM(E5:E168) SubSum =SUBTOTAL(9,E5:E168)
2 |Average =AVERAGE(E5:E168) SubAvg =SUBTOTAL(1,E5:E168)
3 |Count =COUNT(E5:E168) SubCount =SUBTOTAL(2 E5:E168)
4
5 |Quarter |7 Item I Size - Color -7 /# Sold -
43 |2nd Quarter pants Large Red 8
46 |2nd Quarter pants Medium Red G
49 |2nd Quarter pants Small Red 10
168
169




Other Summary Tools
Subtotal Outlines

One way to sum up a large set of data is to use the
Subtotal tool in the Outline group of the Data tab. This
tool will total sets of related data and insert a subtotal
row into the sheet at each change in the column of your
choosing. It will also create a grand total at the bottom
of the dataset.

This tool is very particular about your sort order. If you
are going to group a column, make sure it is sorted first.

Also pay attention to the Replace Current Subtotals
option, as it does erase the previous totals.

\i

=

-

Subtotal

At each change in:
Quarter

Qse function:

sum

Add subtotal to:

|_| Quarter

=l
Tzlalalz J |:| Page break between groups
1 |al Excel adds outline symbols to the ] summary below data
5 left side of the worksheet. The
6 |1g : l Remaove All ‘ [ 0K J l Cancel
7 1d numbers represent the outline level,
g |15 theplusis used to expand a group,
[-] o and the minus is to collapse a group.
10 |15
11 |15
Pivot Tables —
. . . Create PivotTable ?] M
Another amazing summary tool built into Microsoft
. . '” f' d h' b h Chanse the data that you want to analyze
Excel is the Pivot Table. You'll find this button at the 8 Rk
beginning of the Insert tab. TblefRange:  SheetliSAsLSERisd i
_ Use an external data source
By default, this tool will create a new sheet with a blank e
table on it. You can use the Pivot Table field list to wse this workbook's Data Model
decide where your field names (titles) should be placed ShbeEiwHSee et e POt tepinc Lo e P
.. @ Mew Worksheet
as labels and summarizing the values as needed. N
Location: 5
Every field of the pivot table can be filtered, and once Chiinss Whetis ol WEnk 1o Shoiy b ok
. . [ Add this data to the Data Model
you have multiple levels as seen below, you will see the :
. . O Ci |
collapse/expand buttons as with the Subtotal Outline. ' | 2 |
: A T E TE B IR P 3 T N o ; =
1] I[7 PivotTable Fields  ~*
2 | | ™
3 |Surn of # Soid Choose fields 1o add torepor; | 44 ~
4 | f - Large Large Total - Medium Medium Total - Small Small Total Grand Total | e fo)
5 | Blue  Red White Blue Red White Blue  Red White (|
6 | = 1st Quarter 26 30 26 82 15 2 18 54 36 24 30 a0 226 [v! Quarter =
7 Blouses 4 8 10 30 2 4 3 a 18 14 16 43 87| Ty
8|  Pants 2 2 10 5 7 i 18 2 8 10 30 58| e
9 Socks 10 18 14 42 8 10 9 27 6 2 4 12 at|| | sie
10 | = 2nd Quarter 18 31 N 70 30 19 24 73 26 32 30 28 231 | Color =
11 Blousas 3 a 4 12 16 12 14 42 i 2 L] 18 72| T
12 Pants 8 8 7 21 106 8 24 2 10 8 18 83| Draq fields between areas below:
13 Socks 2 18 10 ar 4 1 2 7 14 20 16 b2 96|
14 | = 3rd Quarter 42 62 48 152 39 49 39 127 66 54 58 178 457 | T HLTERS Il COLUMNS
15 Blouses 8 21 13 42 15 26 18 59 14 12 12 38 !395 Giza =
16 Pants 14 20 19 53 1713 12 42 2 18 20 60 155/ —
17 Socks 0 21 1B 57 710 9 28 v 24 25 80 163 £nin X
18 | = 4th Quarter 62 73 68 193 42 62 48 152 4 61 47 162 497 e A
1% Blouses 6 3 12 49 8 21 13 42 17 N 14 42 133| st sl
20 | Pants an 8 29 5 14 20 19 23 a8 14 ] 31 15B§ Quarier x Sum-of # 5old =
21|  Socks k16 17 9 20 21 16 57 19 36 24 78 205 | tem =
22 |Grand Total 148 196 153 497 126 151 129 406 172 171 1656 508 1411 |
23 | :
[ i Sheet? | Sheetl [ -.é-_. '4 = = = — - Defer Layout Updata
Ready ™ i L ] + 1o%




Class Exercise

- Open file SortCustomers.xlsx

Simple Sorts
- Click in the title CITY in cell D1

- Home Tab -> Sort and Filter -> Sort A to Z (ascending)

- Undo

- Sort is "undone" and selection that was sorted is highlighted

- Select Column D (city)

- Home Tab -> Sort and Filter -> Sort A to Z (ascending)

- Say OK to the message
-Undo

.

Default Sort Order

- Right-click Column A (LAST)

- Insert a Column

- Title the new column SORT (A1)
-In A2 type: 1

-In A3 type: 2

- Select both numbers

- Double-click the fill handle to copy the pattern to the end of the data set

- Sort by CITY
- Sort by SORT

- Delete Column A

A w—

Sort Warning

L

?

Microscft Excel found data next to your selection. Since you have not selected this data, it will

not be sorted.

What do you want to do?

! Continue with the current selection

Cancel | !

Blank Columns
- Select Column B (FIRST)

- Insert a Column

- Sort by CITY Z to A (descending) - Notice the first and last names no longer match up

- Undo - Notice the last name column is left out of the group

- In B1 type: SUFFIX
-Sort by City Zto A

- Undo until the new column (SUFFIX) is gone




Custom Sort - Multiple levels

- Click on the large sort button on the Data tab
- Set the sort order for CITY, BALANCE, and DUE DATE
- Use the Add Level buttons to create new lines

- View the Results

r 3 |
Sort e § N e L P i
+t;:-,]_ Add Level H x Delete Level H EE Copy Level = ‘ Options... I |Z| My data has headers

Column Sort On Order
Sortby |cmmy [»| |values [»] |ztoa (=]
Then by |gaLaNCE |E| |Values |E| Smallest to Largest |E|
Then by | DUE DATE E Values |z| Oldest to Newest E

L

\ oK ] | Cancel
|
P — = - e
Custom Sort - Rearranging

- Open the Custom Sort again

- Select the DUE DATE row and use the arrows to move it a «

- Set the sort order for CITY, DUE DATE, and BALANCE

- View the Results E F G H [

1 CITY ST ZIP BALANCE DUE DATE

2 Gainesville FL 32608 S 501.00 1/15/2016
3 Gainesville FL 32684 $ 51.00 2/15/2016
4 Gainesville FL 32597 S 80.00 2/15/2016
5 Gainesville FL 32597 § 157.00 2/15/2016
6 Gainesville FL 32684 $ 131.00 3/15/2016
7 Gainesville FL 32655 S 270.00 3/15/2016
8 Gainesville FL 32732 § 532.00 3/20/2016

Custom Sort - Resetting

- Click in the Column A (LAST)
- Click the Ascending button
- Open the Custom Sort window

- Sort order has been reset




Custom Sort - by Color

- Open the Custom Sort window
- Sort by Address, Sort on Cell Color, Order Green On Top
- Copy Level and set the Order to Peach on top

- Add Level -> Balance, smallest to largest

¥ T—
Sort p— | P
I +2A-L Add Level “ xgelete Level “ EE Copy Level ”BB Wy data has headers

Column Sort On Order

| |sortby | apDRESS [=] [cell color [=] - onTop |7

| i . .
| Then by | ADDRESS [*] cell color [*] onTop |¥]
I Then by 'BALANCE |z| :Vallzjes |Z| Sméllestto Largest E
|

|

|

QK ] | Cancel
I

- View the Results

Reset to our default sort order

- Click in the column A (LAST)
- Click the Ascending button

Custom Sort - Left to Right (i R re oW
- Open Custom Sort Window [ ase semsitive
- Click on the Options... button Orientation

b
- Change orientation to Sort left to right Sy

- Click OK

[ oK ] | Cancel

-Sortby Row 1,AtoZ

rSDrt e . ~ _— —
e o e - = W -
| add Level “ X Delete Level “ 53 Copy Level ” — v Options... |+'| My data has headers
Rowi Sort On Order
Sorthy Rowi x| values [x] |Atoz [~]

- Columns have rearranged to Address through Zip
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Custom Sort - Left to Right

- Select Row 2, and Insert a row

- Number thecells: 3, 8,4,7,1,2,5,6

A B C D E F G H
1 |ADDRESS |BALANCE CITY DUE DATE FIRST LAST ST ZIP
2 3 8 4 7 1 2 5 6
3 6831NW4thA $§ 236.00 Gainesville 2/10/2017 Annie Adams FL 32655
4 |PO Box 456 S 467.00 Starke 9/25/2018 April Appleton FL 32689
5 234SE45thRoi $ 128.00 Gainesville 12/5/2017 Arnold Arlington FL 32597
6 234PeterPanT $ 17.00 Gainesville 3/25/2017 Bobbie  Brown FL 32597
7 3243SE4thTer S 106.00 Gainesville 5/5/2016 Butch Bruce FL 32608
- Open Custom Sort Window
- Sort by Row 2
- View the result
Custom Sort - Left to Right - Selection
- Select Columns A and B (FIRST and LAST)
- Open Custom Sort window
- Sort by Row 2, Largest to Smallest
- Repeat for Columns G and H (DUE DATE and BALANCE)
- Delete Row 2
Reset to our default sort order
- Click in the Column A (LAST)
- Click the Ascending button
- Title row disappears
- LAST has shuffled down to the L's
- Undo the sort
My data has headers
- Open the custom sort window
- Sort by only lists the column letters for the 8 columns in our dataset
- (if it is still offering rows, change the options)
- In the upper right of the window click the My data has D)

headers checkbox

- Sort by LAST, Ato Z

|v"' My data has headers

Order

10




Start over
- Exit Microsoft Excel

- DO NOT SAVE

Instant Filter
- Open SortCustomers.xlsx
- Right-click on a city of Waldo

- Choose Filter -> Filter by Selected Cell's Value

r_a B

SontCustomersadsx - Breel

Insert Page Layout Formulas Data Review View

; Tell me what you want to do..

*** Filter arrows appear on all columns of the data set
*** All rows not matching the criteria have disappeared

*** Row numbers turn blue, but maintain original cell numbers

*** Bottom of the window shows how many records (rows) match

s 2% CHiitn . P — == Zb {General |§‘|3'C0ndili0nal Formatting = | 5= Inseit = b
0 By - - $ -9% » [EPFormatasTable~ PxDelete = [¥]~ O~
Paf‘le . | B F- DRI =—= = s bl < 52 Cell Styles - ElFormat- & -
Clipboard = Fart ] Alignment oo MNumber = Styles Cells Editing * |
D7 - I Waldo ~
A | B | C D E F G | H L]
1 ||ast [~ |FIRST - |ADDRESS [~lcimy TRT-(ZIP  [-|BALANCE -|DUEDATE |-
Cappers Cathy RR 2 Box 659 |Wald0 1FL 34567 S 392.00 9/15/2016
19 |Huey Harley 9023 Hera Terrace Waldo FL 32658 §  219.00 7/5/2016
33 king Kala RR 2 box 323 Waldo FL 34567 S 52.00 11/10/2018
39 |ivingston Lenord 789 North University Ave Waldo FL 32658 S  232.00 4/20/2017
43 |McDade Madeline 8290 Apollo Ave Waldo FL 32658 §  219.00 6/10/2016
50 | Dglethorpe Oprah 9042 Lima Bean Street Waldo FL 32658 &  426.00 8/20/2018
64 |fhomas Tom RR 5 Box 534 Waldo FL 34567 § 242.00 7/20/2018
71 |Yann Vera 9130 Watercress Road Waldo FL 32658 S 236.00 5/20/2016 ||
73 |vest _ Wilma 9203 Sweel Potatoes Ave Waldo FL 32658 §  207.00 1/20/2016 -|
| Sheet1 @ 4 » |
Feady | 9 of 76 records found f"| [ E ] = i —o 115% |

Turn the Filter Off

- From the Sort & Filter button on the Home tab, choose Filter

**% All filter signs will disappear

Filter by Unchecking

- Click the large Filter button on the Data tab

- From the City drop down, uncheck Jacksonville, click OK (67 records)

- From the City drop down, uncheck Gainesville, click OK (12 records)

- From the City drop down, check Select All, click OK

Filter

Tf Advanced

Sort & Filter
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Filter by (Un)Select all

- from the Zip drop down

- uncheck Select All
- check 32608

- click OK (12 records)

Adding another filter

- Keep the 32608 filter

- from the City drop down, uncheck Jacksonville

Y

Filter o
- click OK (9 records) Y Advanced
- from the Data tab, choose the filter Clear button Sort & Filter
Custom number filter Custom AutoFilter | 'EJ ﬁg
Show rows where:
- Balance drop down St
- choose Number Filter Biesshan [z] [s00 2]
Q@ and ior
- choose Less than, type in 100 - =]
- click OK (12 recordS) Use 7 to represent any single character
Use * to represent any series of characters
- Clear the filter
| (]9 ‘ I cancel
Date filter ZIP - |BALANCE - |DUE DATE |-
"l sort Oldest to Newest
- Due Date drop down
- uncheck Select All
- use the expand (+) buttons to open the dates .
- check the first three months of 2016 £i
M (select A1) !.a
- click OK (11 records) l:_zf '
= 2t
111 ¥ January —
:e-i-_'d. February
L+ March
!Ti_!.c.pnl |=
I oK i Cancel |
Custom date filter ; _
Custom AutoFilter | i ‘Q:SJ
- From the Due Date drop down, choose Date Filters I
DUE DATE
h Choose Between ic after ar equal to E T/L/2016 |z| I;|
- type in 7/1/2016, type in 6/30/2017 @ and Dor
yp / / yp / / is before or equal to |L| 6/30,2017 E| E|
- click ok (23 records) _
Use Tto represent any single character
_ Clear the filter Use * to represent any series of characters
[ O ] | Cancel |

12




Custom text filter

- From the Last drop down, choose Text Filter
- Choose Begins with, type J
- click ok (10 records)

- From the Last drop down, choose Text Filter

- Choose Ends with, type S

- click ok (21 records) Custom AutoFilter IM

Show rows where:

- From the Last drop down, choose Text Filter i

beagins with T| ] F|
- Choose Begins with, type ) © and A or
il [ []

- On the second line choose Ends with, type S

Usa ¥ tpAepresent any single character
Use Yto represert any senies of characters

- click ok (6 records)

S I T

oK Cancel

- From the Last drop down, choose Text Filter
- Choose Custom Filter

- Change the bubble (radio button) to OR

- click ok (25 records)

- Clear the filter

Custom text filter

- From the Address drop down, choose Text Filter
- Choose Contains, type Box

- Excel is not case sensitive. BOX = Box = box
- click ok (12 records)
- Clear the filter

Search filter

- From the Address drop down, click inside the Search box

Text Filters
- Type box .

0
**kx* Type it slowly, one letter at a time to see the list

get smaller as you go

[+ (select Al search Results)
Add current selection to filter
78349 Lost Boys Ave
PO Box 1238
FO Box 230
PO Box 3346
PO Box 3072
FO Box 456

- Click ok (12 records
- Clear the filter

QK Cancel
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Filter by Color

- From the Address drop down, choose Filter by color
- Choose the green addresses (13 records)

- Clear the filter

Refreshing Filtered Data

- From the Balance drop down, choose Number Filter

- Choose Greater Than, type 600 Y

- click ok (4 records) Filter

1" Advanced
- Change Edgar's balance to 300

Sort & Filter
- From the Data tab, choose the filter Refresh button (3 records)
- Clear the filter
Copying filtered data
- Use the filter tools to find these 7 records: - Use the filter tools to find these 9 records:
- Balance under 300 - Balance under 350
- Address color has no fill - Address color has no fill
- Due Date in 2018 - Due Date in 2017
- Select All, Copy - Select All, Copy
- Create a new worksheet - Turn to Sheet 2
- Paste in Cell A1 - paste in Cell A11
- Return to Sheet 1 and Clear the filter
A B [ D E F G H ]
1 |LAST -1 FIRST - ADDRESS | ¥ CITY - ST |~ |ZIP - BALANCE |-v DUE DATE Yi
2 |Adams Annie € 6831 NW 4th Gainesville ~ FL 32655 $  236.00 _ : 2/10/ 2.0_1.7'
4 |Arlington Arnold 234 SE 45th RiGainesville FL 32597 § 128.00 12/5/2017.
5 Brown __ _ _ Bobbie . 234 Peter Pan Gainesville _ FL 32597 $ 1700 _ 3 125129_17'
10 Dawson _ _ _ Debbie _ _ ¢ 832 Hook PlacGainesville  FL 32658 S 26500 _11/15/2017;
39 |Livingston _ _ Lenord _ _ 789 North UniWaldo _  _ FL _ 32658 $ 23200 _ 4 1129/.’29_1.7'
51 |Owns _ _ _ _ Owille _ 723 SW 35th [Gainesville _ FL 32655 $  _17.00 _ 6/5/2017;
60 |Saunders  _ _ Samuel _ ¢ 9303 Neverlar Jacksonville | FL _ 32268 $  331.00 _ 7/15/2017
69 Tweed Thomas PO Box 5678 Gainesville FL 32689 § 156.00 9/‘15/2017:
70 |Van Gogh _ Vincent POBox 230 Gainesville ~ FL _ 32684 5 = 91.00 _ 1/10/2017

Notice the copy lines don't go between contiguous rows.
- In Sheet 2, Select ALL of the sheet
- AutoFit the column widths

- Double-click between column headings
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Filter on one data set

- Move to Cell Al (Ctrl Home)
- Turn on the filter
- From the City drop down, uncheck Gainesville

- click ok (4 records)

****Gainesville only disappears from the first list because of the gap

- Turn off the filter

Filter on multiple data sets

- Select all the data columns (not just the data, all the columns A:H)

- Turn on the filter
- Autofit again
- From the City drop down, uncheck Gainesville

- click ok (6 people)

****Gainesville disappears from both lists, but the record count is wrong

- Clear the filter

Filter including gap

- From the City drop down, uncheck Select All
- From the City drop down, check Gainesville
- From the City drop down, check (Blanks)

- From the City drop down, check City

- From the City drop down, uncheck Gainesville

- From the City drop down, check Jacksonville

B C

FIRST | ~ | ADDRESS

Ma 2| SortAtoZ

Rob 2z sortzton

Xer
Sort by Color

7& Clear Filter From "CITY"
FIR
Anr B
Arn Text Filters
Bol Search
Delt| v | | ] (Select All)
Ory CITY
Thc Gainesville
Vin Jacksonville

Waldo
(Blanks)

- | CITY

E

OK

==

Start over
- Exit Microsoft Excel

- DO NOT SAVE
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Set up Grand Total

- Open file SortCustomers.xlsx
- Turn on the Filter
- Go to Cell H79, Type SubTotal
- Go to Cell H80, Type Total
- Go to Cell G80, press the AutoSum button )’ (on the Home or Formulas tab)
- Modify equation to stop at row 78
*x%x =SUM(G2:G78)
- Result: $23,192.00

Set up SubTotal
- Return to the top of the worksheet (Ctrl-Home) 8IS 236.00 i 5/2(
8 S 207.00 | 1/2(
1

- Go to Cell G79, press the AutoSum button. |- —===——————4

- Set City filter to show only Waldo

**** See Page 5 for details on the SubTotal Worksheet Function

- Result: $2,325.00

Viewing the different Subtotals

- From the City drop down, set it so you can only see Starke

- Result: $1,290.00

- From the City drop down, set it so you can only see Jacksonville

- Result: $3,506.00

- From the City drop down, set it so you can only see Gainesville

- Result: $16,071.00

- Clear the filter

Start over
- Exit Microsoft Excel

- DO NOT SAVE
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SubTotal Worksheet Function Exercise

- Open file SortSales.xIsx
1) Insert four rows at the top of the worksheet

a. Select the first four rows

b. Right-click inside the select and choose INSERT

2) Create this table:

A B % D E
1 Sum SubSum
2 Average SubAvg
3 Count SubCount
4
5 Quarter item Size Color # Sold
6 1st Quarter blouses Large Blue 14

3) Click inside the dataset, turn on the Filter

4) Use the filter tools to find these 3 records:
- Quarter: 2nd Quarter
- Item: Pants

- Color: Red

5) Build the following equations

A B C D E

1 |Sum =5SUM(E5:E168) SubSum  =SUBTOTAL(9,E5:E168)
2 |Average =AVERAGE(ES:E168) SubAvg =SUBTOTAL(1,E5:E168)
3 |Count =COUNT(E5:E168) SubCount =SUBTOTAL(2,E5:E168)
4

9 |Quarter |-T|ltem I Size |~ | Color |7 # Sold v
43 |2nd Quarter pants Large Red 8

46 |2nd Quarter pants Medium Red 6

49 2nd Quarter pants Small Red 10

168

169

You have to go above and below the showing numbers so that you include all the hidden cells!

6) View Page 5 for the "answers"

7) Clear the filter, the numbers in Column E should match the numbers in Column B
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